]> code.ossystems Code Review - openembedded-core.git/commitdiff
apt: fix builds with modern GCC
authorJoshua Lock <josh@linux.intel.com>
Fri, 23 Jul 2010 16:33:31 +0000 (17:33 +0100)
committerJoshua Lock <josh@linux.intel.com>
Mon, 2 Aug 2010 17:08:30 +0000 (18:08 +0100)
Signed-off-by: Joshua Lock <josh@linux.intel.com>
meta/packages/apt/apt-0.7.14/includes-fix.patch [new file with mode: 0644]
meta/packages/apt/apt-native.inc
meta/packages/apt/apt-native_0.7.14.bb
meta/packages/apt/apt.inc
meta/packages/apt/apt_0.7.14.bb

diff --git a/meta/packages/apt/apt-0.7.14/includes-fix.patch b/meta/packages/apt/apt-0.7.14/includes-fix.patch
new file mode 100644 (file)
index 0000000..f466164
--- /dev/null
@@ -0,0 +1,42 @@
+Add missing includes required when building with modern toolchain, based on
+patch from Debian bugzilla:
+http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=505954
+
+Should no longer be required once upgraded to 0.7.22 or later.
+
+Index: apt-0.7.14/apt-pkg/acquire.cc
+===================================================================
+--- apt-0.7.14.orig/apt-pkg/acquire.cc 2008-05-28 14:22:13.000000000 +0100
++++ apt-0.7.14/apt-pkg/acquire.cc      2010-07-23 17:30:11.494883936 +0100
+@@ -22,6 +22,7 @@
+ #include <apti18n.h>
++#include <cstdio>
+ #include <iostream>
+ #include <sstream>
+     
+Index: apt-0.7.14/apt-pkg/contrib/sha256.h
+===================================================================
+--- apt-0.7.14.orig/apt-pkg/contrib/sha256.h   2008-05-28 14:22:14.000000000 +0100
++++ apt-0.7.14/apt-pkg/contrib/sha256.h        2010-07-23 17:30:11.494883936 +0100
+@@ -14,6 +14,7 @@
+ #ifndef APTPKG_SHA256_H
+ #define APTPKG_SHA256_H
++#include <stdint.h>
+ #include <string>
+ #include <cstring>
+ #include <algorithm>
+Index: apt-0.7.14/apt-pkg/deb/dpkgpm.cc
+===================================================================
+--- apt-0.7.14.orig/apt-pkg/deb/dpkgpm.cc      2008-05-28 14:22:14.000000000 +0100
++++ apt-0.7.14/apt-pkg/deb/dpkgpm.cc   2010-07-23 17:30:36.960856870 +0100
+@@ -20,6 +20,7 @@
+ #include <stdlib.h>
+ #include <fcntl.h>
+ #include <sys/select.h>
++#include <sys/stat.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ #include <signal.h>
index 554ae078febc586e2e18077f9dcea9fd865046ff..b16f99e93c5b02c0ae12f95367c83e112e77278b 100644 (file)
@@ -5,7 +5,7 @@ DEPENDS += "dpkg-native gettext-native"
 PACKAGES = ""
 USE_NLS = "yes"
 
-SRC_URI += "file://db_linking_hack.patch;patch=1"
+SRC_URI += "file://db_linking_hack.patch"
 
 python do_install () {
        bb.build.exec_func('do_install_base', d)
index 268e9df7208459dd0f29541d9ec2466a78e0dfeb..2f04b72cabcba0c12aacd062b0b69439289a324e 100644 (file)
@@ -1,7 +1,8 @@
 require apt-native.inc
 
-PR = "r2"
+PR = "r3"
 
-SRC_URI += "file://nodoc.patch;patch=1 \
-            file://noconfigure.patch;patch=1 \
-           file://no-curl.patch;patch=1"
+SRC_URI += "file://nodoc.patch \
+            file://noconfigure.patch \
+           file://no-curl.patch \
+           file://includes-fix.patch"
index 0913a7fcb4de42e809cc8a24c4edc522bf92afcc..546683f9bc5e406dabe9179d26fc7b737a7ca5fc 100644 (file)
@@ -3,8 +3,8 @@ LICENSE = "GPL"
 SECTION = "base"
 
 SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/apt_${PV}.tar.gz \
-           file://no-ko-translation.patch;patch=1 \
-           file://use-host.patch;patch=1 \
+           file://no-ko-translation.patch \
+           file://use-host.patch \
            "
 
 inherit autotools gettext
index 1a9cf3602d2d70cb155b9a0dd80ccb61759b5010..0ea9b481427a3458c67b3caad8231b8cd9daa4b5 100644 (file)
@@ -3,9 +3,10 @@ RDEPENDS = "dpkg"
 
 require apt.inc
 
-PR = "r2"
+PR = "r3"
 
-SRC_URI += "file://nodoc.patch;patch=1"
+SRC_URI += "file://nodoc.patch \
+           file://includes-fix.patch"
 
 require apt-package.inc