]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/qemuppc: fix console and ethernet
authorBruce Ashfield <bruce.ashfield@windriver.com>
Mon, 23 Jan 2012 17:54:32 +0000 (12:54 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 24 Jan 2012 10:20:04 +0000 (10:20 +0000)
Two issues are fixed with this commit, the ability to use the keyboard
on a graphical qemu boot and enabling ethernet by default on a 3.0
kernel.

The keyboard is fixed via the same method as the other simulations with
the addition of console=tty on the qemu command line.

Ethernet is fixed by adding a dependency of PCNET32 to the qemuppc
configuration, which allows us to build ethernet directly into the image.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
meta/recipes-kernel/linux/linux-yocto_3.0.bb
scripts/runqemu-internal

index 145e54802e07c7dbb4de37f9e73bd36f564cf99f..9a543ab8b95445d65e21e3751ca9524fb7e64924 100644 (file)
@@ -16,7 +16,7 @@ LINUX_KERNEL_TYPE = "preempt-rt"
 
 SRCREV_machine ?= "f1cc220f4ddf434bf254707c83a45794a63f117f"
 SRCREV_machine_qemuppc ?= "8bd5b80cb3243dadc9d6c5c09482c49994dff1a8"
-SRCREV_meta ?= "73dafd44ea875df654129b32b2877f342d5573e4"
+SRCREV_meta ?= "665fea1c249b4f335cb1c9a46a9f2c138d611f1a"
 
 PR = "r1"
 PV = "${LINUX_VERSION}+git${SRCPV}"
index 0b79beec23971c0906db2932a02b85646856da8c..10859e70666dc7cfe0310019fdd1afd5f1f0ccb3 100644 (file)
@@ -19,7 +19,7 @@ SRCREV_machine_qemuppc ?= "53e71af30e30162e17e32b2f57e4481f5bc0573e"
 SRCREV_machine_qemux86 ?= "9e73573b6b227ab2c62e66e63470866d136f8d76"
 SRCREV_machine_qemux86-64 ?= "3551fd0412965b1f6b0b2f6ba35f7fecdaddb58a"
 SRCREV_machine ?= "6f5b11830deba4a6262c8c4abf67e608924f649e"
-SRCREV_meta ?= "73dafd44ea875df654129b32b2877f342d5573e4"
+SRCREV_meta ?= "665fea1c249b4f335cb1c9a46a9f2c138d611f1a"
 
 PR = "r2"
 PV = "${LINUX_VERSION}+git${SRCPV}"
index 11dda5582e0b93869737c9ca7fb947552f16aa59..21fbce3ee9d8c3ec94491cebfd838bca2ba0a00c 100755 (executable)
@@ -394,7 +394,7 @@ if [ "$MACHINE" = "qemuppc" ]; then
     QEMU_UI_OPTIONS="$QEMU_UI_OPTIONS"
     QEMU_NETWORK_CMD="-net nic,model=pcnet $QEMU_TAP_CMD"
     if [ "$FSTYPE" = "ext3" -o "$FSTYPE" = "btrfs" ]; then
-        KERNCMDLINE="root=/dev/hda rw console=ttyS0 $KERNEL_NETWORK_CMD mem=$QEMU_MEMORY"
+        KERNCMDLINE="root=/dev/hda rw console=ttyS0 console=tty $KERNEL_NETWORK_CMD mem=$QEMU_MEMORY"
         QEMUOPTIONS="$QEMU_NETWORK_CMD -cpu $CPU_SUBTYPE -M $MACHINE_SUBTYPE -hda $ROOTFS -no-reboot $QEMU_UI_OPTIONS"
     fi
     if [ "$FSTYPE" = "nfs" ]; then