]> code.ossystems Code Review - openembedded-core.git/commitdiff
builder: fix adduser breakage with password
authorCristian Iorga <cristian.iorga@intel.com>
Wed, 21 Nov 2012 19:54:24 +0000 (21:54 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 21 Nov 2012 20:38:13 +0000 (20:38 +0000)
Build Appliance needs to have for the builder
user a password set. However, the useradd.bbclass
requires the last parameter to be the user's group
name. Previously, the password was the last
parameter to useradd command.
Fixed using the right order for parameters.

Signed-off-by: Cristian Iorga <cristian.iorga@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/builder/builder_0.1.bb

index 41871d6f1bb52cbebf88d8ffb65b3f31c516e266..78d41e578dc36e88de8b401d5e3d10caed65fd1d 100644 (file)
@@ -1,7 +1,7 @@
 SUMMARY = "New user to do specific job"
 DESCRIPTION = "This recipe create a new user named ${PN}, who is used for specific jobs like building. The task can be auto started via mini X"
 SECTION = "x11"
-PR = "r5"
+PR = "r6"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://builder_hob_start.sh;endline=5;md5=84796c3c41785d86100fdabcbdade00e"
 
@@ -20,8 +20,8 @@ BUILDER_PASSWORD ?= ".gLibiNXn0P12"
 USERADD_PACKAGES = "${PN}"
 USERADD_PARAM_${PN} = "--system --create-home \
                        --groups video,tty,audio \
-                       --user-group ${PN} \
-                       --password ${BUILDER_PASSWORD}"
+                       --password ${BUILDER_PASSWORD} \
+                       --user-group ${PN}"
 
 do_install () {
        install -d -m 755 ${D}${sysconfdir}/mini_x/session.d