]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm: Ensure macros file doesn't reference HOSTTOOLS
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 4 May 2017 10:56:25 +0000 (11:56 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 18 May 2017 12:17:17 +0000 (13:17 +0100)
Currently the file encodes full paths to various host tools in the
HOSTTOOLS directory which is bad in native and target cases. We can
simply use the versions from PATH quite safely in OE.

(From OE-Core rev: be901200d94beaa35e1d05eb502b117b3b523609)

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/rpm/rpm_git.bb

index f31932ef55ab7936671dcf7c388722acaa6684f6..2310ee6b09e0d360aeafe7bfbf97af1e3c976be5 100644 (file)
@@ -128,6 +128,10 @@ do_install_append_class-target() {
     rm -rf ${D}/var
 }
 
+do_install_append () {
+       sed -i -e 's:${HOSTTOOLS_DIR}/::g' ${D}/${libdir}/rpm/macros
+}
+
 FILES_${PN} += "${libdir}/rpm-plugins/*.so \
                "