]> code.ossystems Code Review - openembedded-core.git/commitdiff
openssl_1.1: avoid using += with an over-ride
authorAndre McCurdy <armccurdy@gmail.com>
Fri, 6 Jul 2018 19:05:53 +0000 (12:05 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 7 Jul 2018 10:01:05 +0000 (11:01 +0100)
Using += with an over-ride can be a source of confusion so try to
avoid the construct in core recipes.

The current usage is incorrect and prevents the aarch64 and musl
specific config options from being active together.

Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/openssl/openssl_1.1.0h.bb

index 29f83a31a236b3764e2604240994f3d543df951f..64b8a997d05fff3e73900e2d6d7baecc91a9f8f1 100644 (file)
@@ -126,12 +126,12 @@ do_configure () {
 #| engines/afalg/e_afalg.c:110:20: error: '__NR_eventfd' undeclared (first use in this function)
 #|      return syscall(__NR_eventfd, n);
 #|                     ^~~~~~~~~~~~
-EXTRA_OECONF_aarch64 += "no-afalgeng"
+EXTRA_OECONF_append_aarch64 = " no-afalgeng"
 
 #| ./libcrypto.so: undefined reference to `getcontext'
 #| ./libcrypto.so: undefined reference to `setcontext'
 #| ./libcrypto.so: undefined reference to `makecontext'
-EXTRA_OECONF_libc-musl += "-DOPENSSL_NO_ASYNC"
+EXTRA_OECONF_append_libc-musl = " -DOPENSSL_NO_ASYNC"
 
 do_install () {
         oe_runmake DESTDIR="${D}" MANDIR="${mandir}" MANSUFFIX=ssl install