]> code.ossystems Code Review - openembedded-core.git/commitdiff
strace: Fix build with glibc 2.28
authorKhem Raj <raj.khem@gmail.com>
Mon, 6 Aug 2018 22:57:05 +0000 (15:57 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 8 Aug 2018 09:51:28 +0000 (10:51 +0100)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/strace/strace/0001-tests-fix-build-with-fresh-glibc.patch [new file with mode: 0644]
meta/recipes-devtools/strace/strace_4.23.bb

diff --git a/meta/recipes-devtools/strace/strace/0001-tests-fix-build-with-fresh-glibc.patch b/meta/recipes-devtools/strace/strace/0001-tests-fix-build-with-fresh-glibc.patch
new file mode 100644 (file)
index 0000000..ce6e567
--- /dev/null
@@ -0,0 +1,42 @@
+From bba1b0085f2a2c83839647fee48628ee054aceb7 Mon Sep 17 00:00:00 2001
+From: "Dmitry V. Levin" <ldv@altlinux.org>
+Date: Sun, 15 Jul 2018 22:14:29 +0000
+Subject: [PATCH] tests: fix build with fresh glibc
+
+Workaround additional incompatibility between <sys/stat.h> and
+<asm/stat.h> introduced by glibc-2.27.9000-566-gfd70af4.
+
+* tests/xstatx.c (statx, statx_timestamp): Redefine before the inclusion
+of <sys/stat.h> to avoid conflicts between definitions provided by the
+linux kernel headers and the GNU libc.
+
+Upstream-Status: Backport [https://gitlab.com/strace/strace/commit/3dbffb7]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+
+ tests/xstatx.c | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/tests/xstatx.c b/tests/xstatx.c
+index 7fb9326..441f4a8 100644
+--- a/tests/xstatx.c
++++ b/tests/xstatx.c
+@@ -64,10 +64,14 @@ typedef off_t libc_off_t;
+ # define stat libc_stat
+ # define stat64 libc_stat64
++# define statx libc_statx
++# define statx_timestamp libc_statx_timestamp
+ # include <fcntl.h>
+ # include <sys/stat.h>
+-# undef stat
++# undef statx_timestamp
++# undef statx
+ # undef stat64
++# undef stat
+ # undef st_atime
+ # undef st_mtime
+-- 
+2.18.0
+
index 0c159fc6f6b7096be4fa6f2496c198f845f24d7b..d30d440abc69d70a4d44bbe9fa1340c1eecb4fd1 100644 (file)
@@ -14,6 +14,7 @@ SRC_URI = "https://strace.io/files/${PV}/strace-${PV}.tar.xz \
            file://mips-SIGEMT.patch \
            file://0001-caps-abbrev.awk-fix-gawk-s-path.patch \
            file://0001-tests-sigaction-Check-for-mips-and-alpha-before-usin.patch \
+           file://0001-tests-fix-build-with-fresh-glibc.patch \
            "
 SRC_URI[md5sum] = "fad4bba0947553cef34d46a9fd78f039"
 SRC_URI[sha256sum] = "7860a6965f1dd832747bd8281a04738274398d32c56e9fbd0a68b1bb9ec09aad"