]> code.ossystems Code Review - openembedded-core.git/commitdiff
iproute2: Upgrade 4.10.0 -> 4.11.0
authorChanghyeok Bae <changhyeok.bae@gmail.com>
Mon, 12 Jun 2017 05:44:30 +0000 (05:44 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 13 Jun 2017 09:46:30 +0000 (10:46 +0100)
0001-ip-Remove-unneed-header.patch is to fix build error
built with musl.

Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/iproute2/iproute2/0001-ip-Remove-unneed-header.patch [new file with mode: 0644]
meta/recipes-connectivity/iproute2/iproute2_4.11.0.bb [moved from meta/recipes-connectivity/iproute2/iproute2_4.10.0.bb with 69% similarity]

diff --git a/meta/recipes-connectivity/iproute2/iproute2/0001-ip-Remove-unneed-header.patch b/meta/recipes-connectivity/iproute2/iproute2/0001-ip-Remove-unneed-header.patch
new file mode 100644 (file)
index 0000000..a9f8db6
--- /dev/null
@@ -0,0 +1,30 @@
+From f58fc99c88a54135e55a6e0956ce8ae71078d1cc Mon Sep 17 00:00:00 2001
+From: Changhyeok Bae <changhyeok.bae@gmail.com>
+Date: Mon, 12 Jun 2017 04:29:07 +0000
+Subject: [PATCH] ip: Remove unneed header
+
+Fix redefinition of struct ethhdr with a suitably patched musl libc
+that suppresses the kernel if_ether.h.
+
+Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com>
+
+Upstream-Status: Submitted [netdev@vger.kernel.org]
+---
+ ip/iplink_bridge.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/ip/iplink_bridge.c b/ip/iplink_bridge.c
+index 818b43c..f065b22 100644
+--- a/ip/iplink_bridge.c
++++ b/ip/iplink_bridge.c
+@@ -15,7 +15,6 @@
+ #include <netinet/in.h>
+ #include <linux/if_link.h>
+ #include <linux/if_bridge.h>
+-#include <netinet/ether.h>
+ #include <net/if.h>
+ #include "rt_names.h"
+-- 
+2.7.4
+
similarity index 69%
rename from meta/recipes-connectivity/iproute2/iproute2_4.10.0.bb
rename to meta/recipes-connectivity/iproute2/iproute2_4.11.0.bb
index 063d467440b93a0eb5d9f8063aa90d4cbcb3b50e..dbd05454363a393ddfa1beeafe839cce0a424c99 100644 (file)
@@ -5,10 +5,11 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/utils/net/${BPN}/${BP}.tar.xz \
            file://0001-iproute2-de-bash-scripts.patch \
            file://0001-libc-compat.h-add-musl-workaround.patch \
            file://0001-include-stdint.h-explicitly-for-UINT16_MAX.patch \
+           file://0001-ip-Remove-unneed-header.patch \
           "
 
-SRC_URI[md5sum] = "b94a2b0edefaeac124dc8f5d006931b9"
-SRC_URI[sha256sum] = "22b1e1c1fc704ad35837e5a66103739727b8b48ac90b48c13f79b7367ff0a9a8"
+SRC_URI[md5sum] = "7a9498de88bcca95c305df6108ae197e"
+SRC_URI[sha256sum] = "72671028bda696d0cb8f48ec8e702581c3a501caeed33eec3a81d7041cbc8026"
 
 # CFLAGS are computed in Makefile and reference CCOPTS
 #