]> code.ossystems Code Review - openembedded-core.git/commitdiff
alsa-lib: upgrade 1.2.4 -> 1.2.5
authorAndreas Müller <schnitzeltony@gmail.com>
Thu, 3 Jun 2021 15:43:08 +0000 (17:43 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 6 Jun 2021 22:14:12 +0000 (23:14 +0100)
* Backported patch can go
* See full changelog at [1]

[1] https://github.com/alsa-project/alsa-lib/releases/tag/v1.2.5

Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-multimedia/alsa/alsa-lib/0001-ucm_exec.c-Include-limits.h-explicitly-to-fix-build-.patch [new file with mode: 0644]
meta/recipes-multimedia/alsa/alsa-lib/ad8c8e5503980295dd8e5e54a6285d2d7e32eb1e.patch [deleted file]
meta/recipes-multimedia/alsa/alsa-lib_1.2.5.bb [moved from meta/recipes-multimedia/alsa/alsa-lib_1.2.4.bb with 89% similarity]

diff --git a/meta/recipes-multimedia/alsa/alsa-lib/0001-ucm_exec.c-Include-limits.h-explicitly-to-fix-build-.patch b/meta/recipes-multimedia/alsa/alsa-lib/0001-ucm_exec.c-Include-limits.h-explicitly-to-fix-build-.patch
new file mode 100644 (file)
index 0000000..8752ef0
--- /dev/null
@@ -0,0 +1,41 @@
+From 26ab44c99e9f370e3da0c18982fa482e2e55f0a8 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+Date: Thu, 3 Jun 2021 12:29:03 +0200
+Subject: [PATCH] ucm_exec.c: Include limits.h explicitly to fix build on musl
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Fixes:
+| ../../../alsa-lib-1.2.5/src/ucm/ucm_exec.c: In function 'find_exec':
+| ../../../alsa-lib-1.2.5/src/ucm/ucm_exec.c:43:18: error: 'PATH_MAX' undeclared (first use in this function)
+|    43 |         char bin[PATH_MAX];
+|       |                  ^~~~~~~~
+| ../../../alsa-lib-1.2.5/src/ucm/ucm_exec.c:43:18: note: each undeclared identifier is reported only once for each function it appears in
+| ../../../alsa-lib-1.2.5/src/ucm/ucm_exec.c: In function 'uc_mgr_exec':
+| ../../../alsa-lib-1.2.5/src/ucm/ucm_exec.c:177:18: error: 'PATH_MAX' undeclared (first use in this function)
+|   177 |         char bin[PATH_MAX];
+|       |                  ^~~~~~~~
+
+Upstream-Status: Submitted [https://github.com/alsa-project/alsa-lib/pull/145]
+
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+---
+ src/ucm/ucm_exec.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/ucm/ucm_exec.c b/src/ucm/ucm_exec.c
+index d83206d0..4ddf5d15 100644
+--- a/src/ucm/ucm_exec.c
++++ b/src/ucm/ucm_exec.c
+@@ -30,6 +30,7 @@
+ #include "ucm_local.h"
+ #include <sys/stat.h>
+ #include <sys/wait.h>
++#include <limits.h>
+ #include <dirent.h>
+ static pthread_mutex_t fork_lock = PTHREAD_MUTEX_INITIALIZER;
+-- 
+2.31.1
+
diff --git a/meta/recipes-multimedia/alsa/alsa-lib/ad8c8e5503980295dd8e5e54a6285d2d7e32eb1e.patch b/meta/recipes-multimedia/alsa/alsa-lib/ad8c8e5503980295dd8e5e54a6285d2d7e32eb1e.patch
deleted file mode 100644 (file)
index 98e2988..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From ad8c8e5503980295dd8e5e54a6285d2d7e32eb1e Mon Sep 17 00:00:00 2001
-From: Jaroslav Kysela <perex@perex.cz>
-Date: Thu, 22 Oct 2020 20:57:32 +0200
-Subject: [PATCH] dlmisc: the snd_plugin_dir_set / snd_plugin_dir must be
- declared even for \!DL_ORIGIN_AVAILABLE
-
-Fixes: 8580c081c2 ("dlsym: add support for ALSA_PLUGIN_DIR environment variable")
-BugLink: https://github.com/alsa-project/alsa-lib/issues/91
-Signed-off-by: Jaroslav Kysela <perex@perex.cz>
-Upstream-Status: Backport
-Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
----
- src/dlmisc.c | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/src/dlmisc.c b/src/dlmisc.c
-index c9517c55..f20eb593 100644
---- a/src/dlmisc.c
-+++ b/src/dlmisc.c
-@@ -42,11 +42,9 @@
- #ifndef PIC
- struct snd_dlsym_link *snd_dlsym_start = NULL;
- #endif
--#ifdef DL_ORIGIN_AVAILABLE
- static int snd_plugin_dir_set = 0;
- static char *snd_plugin_dir = NULL;
- #endif
--#endif
- #if defined(DL_ORIGIN_AVAILABLE) && defined(HAVE_LIBPTHREAD)
- static pthread_mutex_t snd_dlpath_mutex = PTHREAD_MUTEX_INITIALIZER;
similarity index 89%
rename from meta/recipes-multimedia/alsa/alsa-lib_1.2.4.bb
rename to meta/recipes-multimedia/alsa/alsa-lib_1.2.5.bb
index c49cc2a9b4253ef4696d13903422f0f1d2682e5c..1d6a9655f6078da6b8418e319da576a0eec79746 100644 (file)
@@ -10,8 +10,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7 \
                     "
 
 SRC_URI = "https://www.alsa-project.org/files/pub/lib/${BP}.tar.bz2 \
-           file://ad8c8e5503980295dd8e5e54a6285d2d7e32eb1e.patch"
-SRC_URI[sha256sum] = "f7554be1a56cdff468b58fc1c29b95b64864c590038dd309c7a978c7116908f7"
+           file://0001-ucm_exec.c-Include-limits.h-explicitly-to-fix-build-.patch"
+SRC_URI[sha256sum] = "9092894a8c083b33acf8d6deb901b58f5d20d6da583789f814e8e46f2850ef18"
 
 inherit autotools pkgconfig