]> code.ossystems Code Review - openembedded-core.git/commitdiff
ruby: fix reproducibility
authorAlexander Kanavin <alex.kanavin@gmail.com>
Thu, 3 Dec 2020 13:37:20 +0000 (14:37 +0100)
committerAnuj Mittal <anuj.mittal@intel.com>
Tue, 22 Dec 2020 01:42:34 +0000 (09:42 +0800)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 07c26e3292dbaf71873f71bec2a631f880b2e76d)
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
meta/recipes-devtools/ruby/ruby/0001-template-Makefile.in-do-not-write-host-cross-cc-item.patch [new file with mode: 0644]
meta/recipes-devtools/ruby/ruby_2.7.1.bb

diff --git a/meta/recipes-devtools/ruby/ruby/0001-template-Makefile.in-do-not-write-host-cross-cc-item.patch b/meta/recipes-devtools/ruby/ruby/0001-template-Makefile.in-do-not-write-host-cross-cc-item.patch
new file mode 100644 (file)
index 0000000..826daf2
--- /dev/null
@@ -0,0 +1,32 @@
+From 2368d07660a93a2c41d63f3ab6054ca4daeef820 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Tue, 17 Nov 2020 18:31:40 +0000
+Subject: [PATCH] template/Makefile.in: do not write host cross-cc items into
+ target config
+
+This helps reproducibility.
+
+Upstream-Status: Inapproppriate [oe-core specific]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ template/Makefile.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/template/Makefile.in b/template/Makefile.in
+index 10dc826..940ee07 100644
+--- a/template/Makefile.in
++++ b/template/Makefile.in
+@@ -657,11 +657,11 @@ mjit_config.h:
+       echo '#endif'; \
+       quote MJIT_MIN_HEADER_NAME "$(MJIT_MIN_HEADER_NAME)"; \
+       sep=,; \
+-      quote "MJIT_CC_COMMON  " $(MJIT_CC); \
++      quote "MJIT_CC_COMMON  " ; \
+       quote "MJIT_CFLAGS      MJIT_ARCHFLAG" $(MJIT_CFLAGS); \
+       quote "MJIT_OPTFLAGS   " $(MJIT_OPTFLAGS); \
+       quote "MJIT_DEBUGFLAGS " $(MJIT_DEBUGFLAGS); \
+-      quote "MJIT_LDSHARED   " $(MJIT_LDSHARED); \
++      quote "MJIT_LDSHARED   " ; \
+       quote "MJIT_DLDFLAGS    MJIT_ARCHFLAG" $(MJIT_DLDFLAGS); \
+       quote "MJIT_LIBS       " $(LIBRUBYARG_SHARED); \
+       quote 'PRELOADENV       "@PRELOADENV@"'; \
index f87686f6f74b8c52acd06d52e12ca4a658b4f9f6..a6c65e887bb6b9e1c44766b3b5c815125b1ada99 100644 (file)
@@ -7,6 +7,7 @@ SRC_URI += " \
            file://run-ptest \
            file://0001-Modify-shebang-of-libexec-y2racc-and-libexec-racc2y.patch \
            file://CVE-2020-25613.patch \
+           file://0001-template-Makefile.in-do-not-write-host-cross-cc-item.patch \
            "
 
 SRC_URI[md5sum] = "debb9c325bf65021214451660f46e909"