]> code.ossystems Code Review - openembedded-core.git/commitdiff
Update tasks to 0.12
authorRoss Burton <ross@openedhand.com>
Sun, 23 Sep 2007 15:32:17 +0000 (15:32 +0000)
committerRoss Burton <ross@openedhand.com>
Sun, 23 Sep 2007 15:32:17 +0000 (15:32 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2773 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/conf/distro/poky.conf
meta/packages/pimlico/files/tasks-owl.diff
meta/packages/pimlico/files/tasks-single.diff [deleted file]
meta/packages/pimlico/tasks-0.10/delete-crash.diff [deleted file]
meta/packages/pimlico/tasks_0.12.bb [moved from meta/packages/pimlico/tasks_0.10.bb with 57% similarity]
meta/packages/pimlico/tasks_svn.bb

index 303745fa64a4826094180f29df9cb604dd5a5e0e..0b7fcbcc27a79f1903aaa94bf90df03a67fd4281 100644 (file)
@@ -105,7 +105,7 @@ SRCDATE_maemo-mapper-nohildon ?= "20061114"
 SRCREV_pn-exmap-console ?= "266"
 SRCREV_pn-gtk-sato-engine ?= "90"
 SRCREV_pn-matchbox-theme-sato ?= "90"
-SRCDATE_tasks ?= "20070711"
+SRCREV_pn-tasks ?= "338"
 SRCREV_pn-sato-icon-theme ?= "90"
 SRCREV_pn-matchbox-desktop-sato ?= "76"
 SRCREV_pn-evince ?= "2437"
index ea867d890d30617707534e368b9689c55b6d5a22..ce1ed9db7e56c2077920f6f62fa296158758e916 100644 (file)
@@ -1,14 +1,24 @@
 Index: src/gtk/tasks-ui.xml
 ===================================================================
---- src/gtk/tasks-ui.xml       (revision 288)
+--- src/gtk/tasks-ui.xml       (revision 338)
 +++ src/gtk/tasks-ui.xml       (working copy)
-@@ -10,10 +10,8 @@
+@@ -7,17 +7,14 @@
+       <menuitem action="EditTask"/>
+       <menuitem action="CompleteTask"/>
+       <separator/>
++      <menuitem action="Undo"/>
++      <menuitem action="Redo"/>
++      <separator/>
        <menuitem action="DeleteTask"/>
        <menuitem action="PurgeTasks"/>
        <separator/>
 +      <menuitem action="About"/>
        <menuitem action="Quit"/>
      </menu>
+-    <menu action="EditMenu">
+-      <menuitem action="Undo"/>
+-      <menuitem action="Redo"/>
+-    </menu>
 -    <menu action="HelpMenu">
 -      <menuitem action="About"/>
 -    </menu>
@@ -16,7 +26,7 @@ Index: src/gtk/tasks-ui.xml
  </ui>
 Index: src/gtk/main.c
 ===================================================================
---- src/gtk/main.c     (revision 288)
+--- src/gtk/main.c     (revision 338)
 +++ src/gtk/main.c     (working copy)
 @@ -21,6 +21,7 @@
  #include <libecal/e-cal.h>
@@ -25,50 +35,28 @@ Index: src/gtk/main.c
 +#include <owlwindowmenu.h>
  
  #include <libkoto/ical-util.h>
- #include <libkoto/koto-category-group.h>
-@@ -462,17 +463,6 @@
-                          NULL);
- }
--/*
-- * Callback from the UI manager with the GtkMenu widget. Pack and add this to
-- * the container.
-- */
--static void
--ui_add_widget (GtkUIManager *ui, GtkWidget *widget, GtkContainer *container)
--{
--  gtk_box_pack_start (GTK_BOX (container), widget, FALSE, FALSE, 0);
--  gtk_widget_show (widget);
--}
--
- /* TODO: split into global actions and actions that require a task to be selected */
- static const GtkActionEntry actions[] = 
- {
-@@ -563,11 +553,12 @@
-   }
-   /* Bind the accelerators */
+ #include <libkoto/koto-actions.h>
+@@ -564,8 +565,8 @@
    gtk_window_add_accel_group (GTK_WINDOW (window), gtk_ui_manager_get_accel_group (ui_manager));
--  g_signal_connect (ui_manager, "add-widget", G_CALLBACK (ui_add_widget), top_box);
-   /* Do this so that the menu is packed now instead of in the idle loop */
    gtk_ui_manager_ensure_update (ui_manager);
--
-+  owl_set_window_menu_item (GTK_WINDOW (window),
-+                            GTK_MENU_ITEM (gtk_ui_manager_get_widget (ui_manager, "/MenuBar/TasksMenu")));
-+  
+-  menu = gtk_ui_manager_get_widget (ui_manager, "/MenuBar");
+-  gtk_box_pack_start (GTK_BOX (top_box), menu, FALSE, FALSE, 0);
++  menu = gtk_ui_manager_get_widget (ui_manager, "/MenuBar/TasksMenu");
++  owl_set_window_menu_item (GTK_WINDOW (window), GTK_MENU_ITEM (menu));
    box = gtk_vbox_new (FALSE, 4);
    gtk_container_set_border_width (GTK_CONTAINER (box), 4);
-   gtk_container_add (GTK_CONTAINER (top_box), box);
 Index: src/gtk/Makefile.am
 ===================================================================
---- src/gtk/Makefile.am        (revision 288)
+--- src/gtk/Makefile.am        (revision 338)
 +++ src/gtk/Makefile.am        (working copy)
 @@ -4,7 +4,7 @@
  bin_PROGRAMS = tasks
  tasks_CPPFLAGS = -I$(top_srcdir)/
- tasks_CFLAGS = -Wall $(GTK_CFLAGS) $(ECAL_CFLAGS) $(SEXY_CFLAGS)
+ tasks_CFLAGS = $(WARN_CFLAGS) $(GTK_CFLAGS) $(ECAL_CFLAGS) $(SEXY_CFLAGS)
 -tasks_LDADD = $(top_builddir)/libkoto/libkoto.a $(GTK_LIBS) $(ECAL_LIBS) $(SEXY_LIBS) 
-+tasks_LDADD = $(top_builddir)/libkoto/libkoto.a $(GTK_LIBS) $(ECAL_LIBS) $(SEXY_LIBS) -lowl
++tasks_LDADD = $(top_builddir)/libkoto/libkoto.a $(GTK_LIBS) $(ECAL_LIBS) $(SEXY_LIBS)  -lowl
  
  tasks_SOURCES = \
        main.c \
diff --git a/meta/packages/pimlico/files/tasks-single.diff b/meta/packages/pimlico/files/tasks-single.diff
deleted file mode 100644 (file)
index dd807ea..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-Index: tasks/data/tasks.desktop.in
-===================================================================
---- tasks/data/tasks.desktop.in        (revision 115)
-+++ tasks/data/tasks.desktop.in        (working copy)
-@@ -9,3 +9,4 @@
- Categories=GTK;Application;Office;ProjectManagement;
- Terminal=false
- StartupNotify=true
-+SingleInstance=true
diff --git a/meta/packages/pimlico/tasks-0.10/delete-crash.diff b/meta/packages/pimlico/tasks-0.10/delete-crash.diff
deleted file mode 100644 (file)
index 0b2ba47..0000000
+++ /dev/null
@@ -1,71 +0,0 @@
-Index: libkoto/koto-utils.c
-===================================================================
---- libkoto/koto-utils.c       (revision 294)
-+++ libkoto/koto-utils.c       (revision 295)
-@@ -25,6 +25,7 @@
- typedef struct {
-   GtkWindow *window;
-+  GtkTreeModel *model;
-   char *title;
- } WindowData;
-@@ -67,19 +68,21 @@
- /*
-  * Update the window title, generally as the number of tasks has changed.
-  */
--static void
--update_title (WindowData *data, GtkTreeModel *model)
-+static gboolean
-+update_title (gpointer user_data)
- {
-+  WindowData *data = user_data;
-   int count = 0;
-   char *title;
-   g_assert (data);
--  g_assert (model);
--  gtk_tree_model_foreach (model, count_pending, &count);
-+  gtk_tree_model_foreach (data->model, count_pending, &count);
-   title = g_strdup_printf (data->title, count);
-   gtk_window_set_title (data->window, title);
-   g_free (title);
-+
-+  return FALSE;
- }
- /*
-@@ -89,7 +92,7 @@
- static void
- on_row_inserted (GtkTreeModel *model, GtkTreePath *path, GtkTreeIter *iter, WindowData *data)
- {
--  update_title (data, model);
-+  g_idle_add (update_title, data);
- }
- /*
-@@ -99,7 +102,7 @@
- static void
- on_row_deleted (GtkTreeModel *model, GtkTreePath *path, WindowData *data)
- {
--  update_title (data, model);
-+  g_idle_add (update_title, data);
- }
- /*
-@@ -135,6 +138,7 @@
-   
-   data = g_slice_new (WindowData);
-   data->window = window;
-+  data->model = model;
-   data->title = g_strdup (title);
-   
-   g_object_weak_ref (G_OBJECT (model), on_weak_notify, data);
-@@ -145,5 +149,5 @@
-                     "signal::row-deleted", G_CALLBACK (on_row_deleted), data,
-                     NULL);
--  update_title (data, model);
-+  update_title (data);
- }
similarity index 57%
rename from meta/packages/pimlico/tasks_0.10.bb
rename to meta/packages/pimlico/tasks_0.12.bb
index 75e589e740c5090be15947967aa321510223744b..ff8da563e690d881d3c4b15cd9ffc0cb02f1672d 100644 (file)
@@ -1,8 +1,4 @@
 require tasks.inc
 
-PR="r2"
-
 SRC_URI = "http://pimlico-project.org/sources/${PN}/${PN}-${PV}.tar.gz \
-        file://tasks-single.diff;patch=1 \
-        file://delete-crash.diff;patch=1;pnum=0 \
         file://tasks-owl.diff;patch=1;pnum=0"
index b3da6ebe20ced42f194b218e7d536c0afb934e02..be3a8d0978cfd3c39449440eec78f8201e70fc55 100644 (file)
@@ -2,9 +2,8 @@ require tasks.inc
 
 DEFAULT_PREFERENCE = "-1"
 
-PV = "0.10+svnr${SRCREV}"
+PV = "0.12+svnr${SRCREV}"
 S = "${WORKDIR}/trunk"
 
 SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \
-        file://tasks-single.diff;patch=1 \
         file://tasks-owl.diff;patch=1"