]> code.ossystems Code Review - openembedded-core.git/commitdiff
package_*.bbclass: remove references to the old bash indexing routines
authorLaurentiu Palcu <laurentiu.palcu@intel.com>
Fri, 14 Feb 2014 11:01:07 +0000 (13:01 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 14 Feb 2014 12:25:14 +0000 (12:25 +0000)
Package indexing is done in python and package-index.bb uses the new
routines.

Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/package_deb.bbclass
meta/classes/package_ipk.bbclass
meta/classes/package_rpm.bbclass

index a0a31bd0f686d217691054894e7351de446cd45b..b9d797833a2356cc026e0865b1d7e6f29458ecaa 100644 (file)
@@ -309,6 +309,5 @@ do_package_write_deb[umask] = "022"
 addtask package_write_deb before do_package_write after do_packagedata do_package
 
 
-PACKAGEINDEXES += "[ ! -e ${DEPLOY_DIR_DEB} ] || package_update_index_deb;"
 PACKAGEINDEXDEPS += "dpkg-native:do_populate_sysroot"
 PACKAGEINDEXDEPS += "apt-native:do_populate_sysroot"
index 516ec4b3d26a678cbeef868c7fa47f2506185872..7cf2c8af2d0edfc55f5ed0c1618fdf631e986a6c 100644 (file)
@@ -255,6 +255,5 @@ do_package_write_ipk[cleandirs] = "${PKGWRITEDIRIPK}"
 do_package_write_ipk[umask] = "022"
 addtask package_write_ipk before do_package_write after do_packagedata do_package
 
-PACKAGEINDEXES += "[ ! -e ${DEPLOY_DIR_IPK} ] || package_update_index_ipk;"
 PACKAGEINDEXDEPS += "opkg-utils-native:do_populate_sysroot"
 PACKAGEINDEXDEPS += "opkg-native:do_populate_sysroot"
index 82ea187479819e4b30774735855d15b30056f05e..f267b8a4cb3aa2c706daa38fb450120c24ba0149 100644 (file)
@@ -734,6 +734,5 @@ do_package_write_rpm[cleandirs] = "${PKGWRITEDIRRPM}"
 do_package_write_rpm[umask] = "022"
 addtask package_write_rpm before do_package_write after do_packagedata do_package
 
-PACKAGEINDEXES += "[ ! -e ${DEPLOY_DIR_RPM} ] || package_update_index_rpm;"
 PACKAGEINDEXDEPS += "rpm-native:do_populate_sysroot"
 PACKAGEINDEXDEPS += "createrepo-native:do_populate_sysroot"