]> code.ossystems Code Review - openembedded-core.git/commitdiff
libidn2: remove build paths from libidn2.pc
authorRoss Burton <ross.burton@intel.com>
Thu, 25 Jul 2019 15:20:22 +0000 (16:20 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 26 Jul 2019 07:40:59 +0000 (08:40 +0100)
The libunistring m4 macros end up putting the full build-time library path into
the .pc file, which is no good on target.  Sed it out to stop build paths
leaking onto the target.

[ YOCTO #13403 ]

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/libidn/libidn2_2.2.0.bb

index d7fec89fba297d6bc76877f55781ed45466006fd..bcbfdd85b91301c77a798057ebb0dccb89668d86 100644 (file)
@@ -21,6 +21,10 @@ EXTRA_OECONF += "--disable-rpath \
                  --with-libunistring-prefix=${STAGING_EXECPREFIXDIR} \
                  "
 
+do_install_append() {
+       sed -i -e 's|-L${STAGING_LIBDIR}||' ${D}${libdir}/pkgconfig/libidn2.pc
+}
+
 LICENSE_${PN} = "(GPLv2+ | LGPLv3)"
 LICENSE_${PN}-bin = "GPLv3+"