]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm: ensure __mkdir_p matches __mkdir
authorSaul Wold <sgw@linux.intel.com>
Tue, 7 May 2013 15:26:04 +0000 (08:26 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 10 May 2013 10:43:08 +0000 (11:43 +0100)
They differ at times because one is set from the db_cv_path_mkdir and the other is
found during config time for the host (/usr/bin/mkdir), in the macros we should just
use __mkdir for the __mkdir_p variant.

[YOCTO #4452]

Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/rpm/rpm_5.4.9.bb

index 112d11d03b0ec1aab0852f55185dda3078d388b9..2dbdca6e6fcb07dcfc88e5eff2876e10d8b1c5b6 100644 (file)
@@ -360,6 +360,7 @@ FILES_${PN}-staticdev = " \
 do_configure() {
        # Disable tests!
        echo "all:" > ${S}/tests/Makefile.am
+       sed -e 's/@__MKDIR_P@/%{__mkdir} -p/' -i ${S}/macros/macros.in
 
        ( cd ${S}; ${S}/autogen.sh )