]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3-pyyaml: upgrade 5.4.1 -> 6.0
authorTim Orling <ticotimo@gmail.com>
Wed, 20 Oct 2021 18:57:25 +0000 (18:57 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 23 Oct 2021 16:41:46 +0000 (17:41 +0100)
Now uses "vendored" distutils from setuptools by default
rather than from Python stdlib.

Changes
=======

* https://github.com/yaml/pyyaml/pull/327
  -- Change README format to Markdown
* https://github.com/yaml/pyyaml/pull/483
  -- Add a test for YAML 1.1 types
* https://github.com/yaml/pyyaml/pull/497
  -- fix float resolver to ignore `.` and `._`
* https://github.com/yaml/pyyaml/pull/550
  -- drop Python 2.7
* https://github.com/yaml/pyyaml/pull/553
  -- Fix spelling of “hexadecimal”
* https://github.com/yaml/pyyaml/pull/556
  -- fix representation of Enum subclasses
* https://github.com/yaml/pyyaml/pull/557
  -- fix libyaml extension compiler warnings
* https://github.com/yaml/pyyaml/pull/560
  -- fix ResourceWarning on leaked file descriptors
* https://github.com/yaml/pyyaml/pull/561
  -- always require `Loader` arg to `yaml.load()`
* https://github.com/yaml/pyyaml/pull/564
  -- remove remaining direct distutils usage

Signed-off-by: Tim Orling <timothy.t.orling@intel.com>
Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python3-pyyaml_6.0.bb [moved from meta/recipes-devtools/python/python3-pyyaml_5.4.1.bb with 81% similarity]

similarity index 81%
rename from meta/recipes-devtools/python/python3-pyyaml_5.4.1.bb
rename to meta/recipes-devtools/python/python3-pyyaml_6.0.bb
index b11baa6331c0bde83844ce34283e57cc89b70208..2df0e649f0a0f1c9a99ecce9a7a21f2cf95e094e 100644 (file)
@@ -9,7 +9,7 @@ PYPI_PACKAGE = "PyYAML"
 
 inherit pypi setuptools3
 
-SRC_URI[sha256sum] = "607774cbba28732bfa802b54baa7484215f530991055bb562efbed5b2f20a45e"
+SRC_URI[sha256sum] = "68fb519c14306fec9720a2a5b45bc9f0c8d1b9c72adf45c37baedfcd949c35a2"
 
 RDEPENDS:${PN} += "\
     ${PYTHON_PN}-datetime \