]> code.ossystems Code Review - openembedded-core.git/commitdiff
self-hosted-image: use the correct location of the file sudoers
authorDexuan Cui <dexuan.cui@intel.com>
Thu, 5 Apr 2012 04:00:05 +0000 (12:00 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 6 Apr 2012 00:11:06 +0000 (01:11 +0100)
Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
meta/recipes-core/images/self-hosted-image.bb

index cf3ef5fd24910755371efb2df348302531cc30f9..d8fd4a963c00a5384b36417f315977190162f2fb 100644 (file)
@@ -50,7 +50,7 @@ fakeroot do_populate_poky_src () {
        chown -R builder.builder  ${IMAGE_ROOTFS}/home/builder/poky
 
        # Allow builder to use sudo to setup tap/tun
-       echo "builder ALL=(ALL) NOPASSWD: ALL" >> /etc/sudoers
+       echo "builder ALL=(ALL) NOPASSWD: ALL" >> ${IMAGE_ROOTFS}/etc/sudoers
 }
 
 IMAGE_PREPROCESS_COMMAND += "do_populate_poky_src; "