]> code.ossystems Code Review - openembedded-core.git/commitdiff
libusb1: Cope with ${libdir} and ${base_libdir} being the same
authorMike Crowe <mac@mcrowe.com>
Mon, 6 Feb 2012 13:33:31 +0000 (13:33 +0000)
committerSaul Wold <sgw@linux.intel.com>
Tue, 7 Feb 2012 22:37:13 +0000 (14:37 -0800)
${libdir} and ${base_libdir} may be the same. If they are don't try and
move files onto themselves.

Signed-off-by: Mike Crowe <mac@mcrowe.com>
meta/recipes-support/libusb/libusb1_1.0.8.bb

index 8873de745a7a5c0011716d45593cdde022f994c3..e45a9d9ae3ed0969d4609f9ee6c800d8a1d2fe6a 100644 (file)
@@ -6,7 +6,7 @@ SECTION = "libs"
 LICENSE = "LGPLv2.1+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
 
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/libusb/libusb-${PV}.tar.bz2"
 
@@ -20,7 +20,9 @@ EXTRA_OECONF = "--libdir=${base_libdir}"
 
 do_install_append() {
        install -d ${D}${libdir}
-       mv ${D}${base_libdir}/pkgconfig ${D}${libdir}
+       if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then
+               mv ${D}${base_libdir}/pkgconfig ${D}${libdir}
+       fi
 }
 
 FILES_${PN} += "${base_libdir}/*.so.*"