]> code.ossystems Code Review - openembedded-core.git/commitdiff
musl: Update to latest
authorKhem Raj <raj.khem@gmail.com>
Tue, 14 Mar 2017 23:35:32 +0000 (16:35 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 17 Mar 2017 15:37:04 +0000 (15:37 +0000)
Rich Felker (11):
      fix ld-behavior-dependent crash in ppc64 ldso startup
      rework ldso handling of global symbol table for consistency
      reorder addend handling before symbol lookup in relocation code
      emulate lazy relocation as deferrable relocation
      fix free of uninitialized buffer pointer on error in regexec
      in static dl_iterate_phdr, fix use of possibly-uninitialized aux data
      fix possible fd leak, unrestored cancellation state on dns socket fail
      fix wide scanf's use of a compound literal past its lifetime
      fix one-byte overflow in legacy getpass function
      avoid loading of multiple libc versions via explicit pathname
      remove unused refcnt field for shared libraries

Szabolcs Nagy (1):
      treat STB_WEAK and STB_GNU_UNIQUE like STB_GLOBAL in find_sym

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/musl/musl_git.bb

index 7156669064d14086b48755ac102eb022cd606d44..fa87d7d3e382d9297c27d631eec92a9f8a046a69 100644 (file)
@@ -3,7 +3,7 @@
 
 require musl.inc
 
-SRCREV = "827c4e6fbe46142049ef3d8bcb8f35951712797d"
+SRCREV = "cb525397bb053ea49cf160965477a17b17286eb3"
 
 PV = "1.1.16+git${SRCPV}"