]> code.ossystems Code Review - openembedded-core.git/commitdiff
kmscube: Fix build when x11 is absent in distro features
authorKhem Raj <raj.khem@gmail.com>
Mon, 7 Mar 2022 04:07:41 +0000 (20:07 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 7 Mar 2022 22:43:47 +0000 (22:43 +0000)
distros might use openGL but not x11 ( e.g. EGL ), therefore fix build for such
combination

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/kmscube/kmscube_git.bb

index 68cbe8c9fbf039665dd69885adcaab0343e573f0..58ce26a3d51607313fc8b17dc57e35c1a99cb484 100644 (file)
@@ -24,3 +24,6 @@ DEPENDS = "virtual/libgbm"
 
 PACKAGECONFIG ??= ""
 PACKAGECONFIG[gstreamer] = "-Dgstreamer=enabled,-Dgstreamer=disabled,gstreamer1.0 gstreamer1.0-plugins-base"
+
+CFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', '-DEGL_NO_X11=1', d)}"
+