]> code.ossystems Code Review - openembedded-core.git/commitdiff
shadow-native: Ensure that ${sbindir} and ${base_sbindir} are respected
authorPhil Blundell <philb@gnu.org>
Sun, 9 Sep 2012 10:48:45 +0000 (11:48 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 12 Sep 2012 13:44:52 +0000 (14:44 +0100)
These values need to be passed on the command line to "make install" otherwise
shadow will use its own built-in idea of where those directories are located.

Signed-off-by: Phil Blundell <pb@pbcl.net>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb

index cd5605f81ccb93aa8dde90aa06b0f587a4e2c9b9..0469306ab0dc9f76d5da0f7702066420663f41d9 100644 (file)
@@ -7,7 +7,7 @@ LICENSE = "BSD | Artistic-1.0"
 LIC_FILES_CHKSUM = "file://COPYING;md5=08c553a87d4e51bbed50b20e0adcaede \
                     file://src/passwd.c;firstline=8;endline=30;md5=2899a045e90511d0e043b85a7db7e2fe"
 
-PR = "r7"
+PR = "r8"
 
 SRC_URI = "http://pkg-shadow.alioth.debian.org/releases/${BPN}-${PV}.tar.bz2 \
            file://shadow.automake-1.11.patch \
@@ -30,7 +30,14 @@ EXTRA_OECONF += "--without-audit \
                  --without-selinux \
                  --without-nscd"
 
-do_install_append() {
+do_install() {
+       oe_runmake DESTDIR="${D}" sbindir="${base_sbindir}" usbindir="${sbindir}" install
+
+       # Info dir listing isn't interesting at this point so remove it if it exists.
+       if [ -e "${D}${infodir}/dir" ]; then
+               rm -f ${D}${infodir}/dir
+       fi
+
        # Enable CREATE_HOME by default.
        sed -i 's/#CREATE_HOME/CREATE_HOME/g' ${D}${sysconfdir}/login.defs