]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/4.1: Bluetooth:Fix the connection fail of 6lowpan over BT LE
authorBruce Ashfield <bruce.ashfield@windriver.com>
Tue, 24 Nov 2015 17:01:30 +0000 (12:01 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 1 Dec 2015 21:31:02 +0000 (21:31 +0000)
Backporting the 4.4 fix for 6lowpan:

   Author: Wu Zheng <wu.zheng@intel.com>
   Date:   Fri Nov 20 13:25:57 2015 +0800

       Bluetooth:Fix the connection fail of 6lowpan over BT LE

       When two devices with 6lowpan over BT LE connect each other,
       6lowpan over BT LE channel is set up between the two devices.
       However, the status of channel is not right.
       It always is set to CONNECTED and the channel can't be created.

       The status of channel need to be removed when connection is created.

       (The patch's reference from
       b0c09f94ff1660a1873549b788c998284ea5fb8a)

Signed-off-by: Wu Zheng <wu.zheng@intel.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
meta/recipes-kernel/linux/linux-yocto_4.1.bb

index d4ac038dd33edc474a758ea73d5ac016c2a8882f..e569d16581051f595ebb7eed900333443a26f569 100644 (file)
@@ -2,7 +2,7 @@ KBRANCH ?= "standard/preempt-rt/base"
 
 require recipes-kernel/linux/linux-yocto.inc
 
-SRCREV_machine ?= "45780656ed0c04f0e70a089ff229a7b0a9af3414"
+SRCREV_machine ?= "44fb75fd4731d1169725ac49a305e0913440974f"
 SRCREV_meta ?= "30c4b4bd79c5d774de6dcf23d0deab554e31f3d4"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;branch=${KBRANCH};name=machine \
index 1d8086c960188113cf0139cec421b4288a374e84..fe04f51d15eaeb78c23fc34ee440b46dfd4ac5f8 100644 (file)
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "4.1.13"
 KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
-SRCREV_machine ?= "ec44c165aa1d30bde477196ee428d82530e55485"
+SRCREV_machine ?= "c22dc676d6d560d0b2a316283a514d65d2a510e4"
 SRCREV_meta ?= "30c4b4bd79c5d774de6dcf23d0deab554e31f3d4"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
index 99c73ddcd8d1e7ad40738fe6fae5ea61dd0498f3..9553f3d2a7f22fa32cc6e1f4e6cff44b3c650624 100644 (file)
@@ -11,14 +11,14 @@ KBRANCH_qemux86  ?= "standard/base"
 KBRANCH_qemux86-64 ?= "standard/base"
 KBRANCH_qemumips64 ?= "standard/mti-malta64"
 
-SRCREV_machine_qemuarm ?= "5039adac938a19aa547f94551126a8421ce62745"
-SRCREV_machine_qemuarm64 ?= "ec44c165aa1d30bde477196ee428d82530e55485"
-SRCREV_machine_qemumips ?= "203b315e50e32ce39f9831b0518ef18f16f61025"
-SRCREV_machine_qemuppc ?= "ec44c165aa1d30bde477196ee428d82530e55485"
-SRCREV_machine_qemux86 ?= "ec44c165aa1d30bde477196ee428d82530e55485"
-SRCREV_machine_qemux86-64 ?= "ec44c165aa1d30bde477196ee428d82530e55485"
-SRCREV_machine_qemumips64 ?= "9223cd7daecddcbdb0818aaa6edfbd90060d1b84"
-SRCREV_machine ?= "ec44c165aa1d30bde477196ee428d82530e55485"
+SRCREV_machine_qemuarm ?= "817a421e7c1be9c1136da5772f351e77513a1ed2"
+SRCREV_machine_qemuarm64 ?= "c22dc676d6d560d0b2a316283a514d65d2a510e4"
+SRCREV_machine_qemumips ?= "9f244d964a5910244fc82c261c48e1dc0862654b"
+SRCREV_machine_qemuppc ?= "c22dc676d6d560d0b2a316283a514d65d2a510e4"
+SRCREV_machine_qemux86 ?= "c22dc676d6d560d0b2a316283a514d65d2a510e4"
+SRCREV_machine_qemux86-64 ?= "c22dc676d6d560d0b2a316283a514d65d2a510e4"
+SRCREV_machine_qemumips64 ?= "7fdfaf2387d7896c1ead6a000616e01ce72f0764"
+SRCREV_machine ?= "c22dc676d6d560d0b2a316283a514d65d2a510e4"
 SRCREV_meta ?= "30c4b4bd79c5d774de6dcf23d0deab554e31f3d4"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;name=machine;branch=${KBRANCH}; \