]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: add liblzma depdenency
authorBruce Ashfield <bruce.ashfield@windriver.com>
Thu, 30 Jul 2015 15:03:14 +0000 (11:03 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 31 Jul 2015 14:35:36 +0000 (15:35 +0100)
With kernel commit 6c6f0f6164f [tools build: Add feature check for lzma
library], perf now performs a test for lzma and adds functionality
appropriately.

This currently is a floating dependency that will sometimes be present,
and sometimes not. The result is the following QA warning:

  WARNING: QA Issue: perf rdepends on liblzma, but it isn't a build dependency? [build-deps]

By adding xz to the DEPENDS, we'll ensure that it is consistently in
place.

[YOCTO: #8045]

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-kernel/perf/perf.bb

index 056ac831f7acc316883e3952b256f5cf4a8594c5..246f1b47f7b8e3d27b109de7a9204cabf32de7a7 100644 (file)
@@ -29,7 +29,7 @@ DEPENDS = " \
     ${TUI_DEPENDS} \
     ${SCRIPTING_DEPENDS} \
     ${LIBUNWIND_DEPENDS} \
-    bison flex \
+    bison flex xz \
 "
 
 do_configure[depends] += "virtual/kernel:do_shared_workdir"