]> code.ossystems Code Review - openembedded-core.git/commitdiff
gstreamer1.0: fix introspection support also for git recipes
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>
Mon, 21 Mar 2016 16:40:09 +0000 (18:40 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 24 Mar 2016 21:44:25 +0000 (21:44 +0000)
This is generally done by moving necessary patches to common
include files, and a few other fixes.

Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad.inc
meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.6.3.bb
meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base.inc
meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.6.3.bb
meta/recipes-multimedia/gstreamer/gstreamer1.0.inc
meta/recipes-multimedia/gstreamer/gstreamer1.0_1.6.3.bb

index a8bff19b1c68724aafcd345e5f760d869f76ecd1..9e2b94ede8c00bb0651b28825905e3f590039893 100644 (file)
@@ -6,6 +6,10 @@ DEPENDS += "gstreamer1.0-plugins-base libpng jpeg"
 
 inherit gettext bluetooth
 
+SRC_URI_append = " \
+    file://0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch \
+"
+
 # opengl packageconfig factored out to make it easy for distros
 # and BSP layers to pick either (desktop) opengl, gles2, or no GL
 PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2', '', d)}"
index 323177b35a2e43e399adfea9743c6da10a4cf6f5..8eb47c265fe428309912f0afd848b9ab0eed8878 100644 (file)
@@ -20,7 +20,6 @@ SRC_URI = " \
     file://configure-allow-to-disable-libssh2.patch \
     file://0001-glimagesink-Downrank-to-marginal.patch \
     file://0002-glplugin-glwindow-fix-memory-leak-of-navigation-thre.patch \
-    file://0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch \
 "
 
 SRC_URI[md5sum] = "4857adcafe41e4b9b8805cf88303bd55"
index f0c80cef79f83575b07e2e8e4af49f11c6cd6fd8..7381458f477b8203df8adb8dda0e9cf030c15a45 100644 (file)
@@ -1,5 +1,12 @@
 require gstreamer1.0-plugins.inc
 
+SRC_URI_append = "\
+    file://0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch \
+    file://0002-Makefile.am-prefix-calls-to-pkg-config-with-PKG_CONF.patch \
+    file://0003-riff-add-missing-include-directories-when-calling-in.patch \
+    file://0004-rtsp-drop-incorrect-reference-to-gstreamer-sdp-in-Ma.patch \
+"
+
 LICENSE = "GPLv2+ & LGPLv2+"
 
 DEPENDS += "iso-codes util-linux zlib"
@@ -39,5 +46,5 @@ CACHED_CONFIGUREVARS_append_x86 = " ac_cv_header_emmintrin_h=no ac_cv_header_xmm
 FILES_${MLPREFIX}libgsttag-1.0 += "${datadir}/gst-plugins-base/1.0/license-translations.dict"
 
 do_compile_prepend() {
-        export GIR_EXTRA_LIBS_PATH="${B}/gst-libs/gst/tag/.libs:${B}/gst-libs/gst/video/.libs:${B}/gst-libs/gst/audio/.libs"
+        export GIR_EXTRA_LIBS_PATH="${B}/gst-libs/gst/tag/.libs:${B}/gst-libs/gst/video/.libs:${B}/gst-libs/gst/audio/.libs:${B}/gst-libs/gst/rtp/.libs"
 }
index 287d287d700159ccb3f1178842f01a8788a2d0af..429dc9338f7f807d3e97d98304b58caa0eb8113d 100644 (file)
@@ -17,10 +17,6 @@ SRC_URI = " \
     file://0004-subparse-set-need_segment-after-sink-pad-received-GS.patch \
     file://encodebin-Need-more-buffers-in-output-queue-for-bett.patch \
     file://0005-convertframe-Support-video-crop-when-convert-frame.patch \
-    file://0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch \
-    file://0002-Makefile.am-prefix-calls-to-pkg-config-with-PKG_CONF.patch \
-    file://0003-riff-add-missing-include-directories-when-calling-in.patch \
-    file://0004-rtsp-drop-incorrect-reference-to-gstreamer-sdp-in-Ma.patch \
 "
 
 SRC_URI[md5sum] = "3ddde0ad598ef69f58d6a2e87f8b460f"
index e8f29ca549e85fed1aa03fff58ec20b737903837..10b4668e5fa9f08aed067fa944cd76eb9b9563cb 100644 (file)
@@ -10,6 +10,14 @@ DEPENDS = "glib-2.0 glib-2.0-native libcap libxml2 bison-native flex-native"
 
 inherit autotools pkgconfig gettext upstream-version-is-even gobject-introspection
 
+# This way common/m4/introspection.m4 will come first
+# (it has a custom INTROSPECTION_INIT macro, and so must be used instead of our common introspection.m4 file)
+acpaths = "-I ${S}/common/m4 -I ${S}/m4"
+
+SRC_URI_append = " \
+    file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
+"
+
 PACKAGECONFIG ??= ""
 
 PACKAGECONFIG[check] = "--enable-check,--disable-check"
index a79f449d0bfb8d9131f5669b003a3d20f4ab8aeb..ba1b83b08c2206f4d892774f230060d867c900ff 100644 (file)
@@ -6,7 +6,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
 SRC_URI = " \
     http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.xz \
     file://0001-Fix-crash-with-gst-inspect.patch \
-    file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
 "
 
 SRC_URI[md5sum] = "b4cdeb2b9cb20dd6ac022a4f417eae0d"