]> code.ossystems Code Review - openembedded-core.git/commitdiff
nautilus: Add based roughly on OE.dev recipe
authorRichard Purdie <rpurdie@linux.intel.com>
Wed, 19 Aug 2009 08:34:11 +0000 (09:34 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 19 Aug 2009 08:34:11 +0000 (09:34 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta-moblin/packages/nautilus/nautilus/idl-sysroot.patch [new file with mode: 0644]
meta-moblin/packages/nautilus/nautilus/no-try-run-strftime.diff [new file with mode: 0644]
meta-moblin/packages/nautilus/nautilus_2.26.1.bb [new file with mode: 0644]

diff --git a/meta-moblin/packages/nautilus/nautilus/idl-sysroot.patch b/meta-moblin/packages/nautilus/nautilus/idl-sysroot.patch
new file mode 100644 (file)
index 0000000..0062cfb
--- /dev/null
@@ -0,0 +1,7 @@
+Index: nautilus-2.24.2/add-include-prefix
+===================================================================
+--- nautilus-2.24.2.orig/add-include-prefix    2008-10-06 17:22:21.000000000 +0000
++++ nautilus-2.24.2/add-include-prefix 2009-04-09 16:00:05.000000000 +0000
+@@ -1 +1 @@
+-sed -e 's/^/ /' -e 's/  */ /g' -e 's/ / -I /g' -e 's/ -I $//'
++sed -e 's:^: :' -e 's:  *: :g' -e 's: : -I '"$SYSROOT"':g' -e 's: -I '"$SYSROOT"'$::'
diff --git a/meta-moblin/packages/nautilus/nautilus/no-try-run-strftime.diff b/meta-moblin/packages/nautilus/nautilus/no-try-run-strftime.diff
new file mode 100644 (file)
index 0000000..ccd2934
--- /dev/null
@@ -0,0 +1,28 @@
+--- /tmp/configure.in  2009-04-13 11:26:43.000000000 +0200
++++ nautilus-2.26.1/configure.in       2009-04-13 11:28:37.000000000 +0200
+@@ -375,25 +375,6 @@
+ dnl ===========================================================================
+-dnl strftime checks
+-
+-AC_TRY_RUN([#include <time.h>
+-                int main ()
+-                {
+-                  char buf[100];
+-                  struct tm tm = {0};
+-                  tm.tm_year = 99;
+-                  if (strftime(buf, 100, "%EY", &tm) == 4 &&
+-                    strcmp (buf, "1999")==0)
+-                    return 0;
+-                  return 1;
+-                }
+-            ],
+-          AC_DEFINE(HAVE_STRFTIME_EXTENSION, 1, [Define if strftime supports %E and %O modifiers.])
+-            )
+-
+-dnl ===========================================================================
+-
+ #
+ # Checks for Xft/XRender
+ #
diff --git a/meta-moblin/packages/nautilus/nautilus_2.26.1.bb b/meta-moblin/packages/nautilus/nautilus_2.26.1.bb
new file mode 100644 (file)
index 0000000..e653ae9
--- /dev/null
@@ -0,0 +1,29 @@
+# nautilus OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc.  All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+inherit gnome
+
+SRC_URI += "file://idl-sysroot.patch;patch=1 \
+            file://no-try-run-strftime.diff;patch=1 \
+"
+
+export SYSROOT = "${STAGING_DIR_HOST}"
+
+LICENSE = "GPL"
+
+DEPENDS = "gail gtk+ pango gnome-desktop libxml2 dbus-glib libunique libexif librsvg"
+#DEPENDS += "gvfs"
+#RDEPENDS = "gvfs gvfsd-ftp gvfsd-sftp gvfsd-trash"
+
+EXTRA_OECONF = " --disable-gtk-doc  --disable-update-mimedb --disable-tracker --disable-beagle"
+
+PACKAGES += " libnautilus"
+
+FILES_${PN} += "${datadir}/icons  /usr/libexec/ "
+FILES_libnautilus = "/usr/lib/*.so*"
+FILES_${PN}-dbg += "/usr/libexec/.debug"
+
+do_configure_prepend() {
+       sed -i -e /docs/d Makefile.am
+}