]> code.ossystems Code Review - openembedded-core.git/commitdiff
clutter: Add recipe for 1.0 release branch
authorRichard Purdie <rpurdie@linux.intel.com>
Tue, 11 Aug 2009 09:45:07 +0000 (10:45 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 11 Aug 2009 09:45:07 +0000 (10:45 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/clutter/clutter-1.0_git.bb [new file with mode: 0644]
meta/packages/clutter/clutter/enable_tests-1.0.patch [new file with mode: 0644]

diff --git a/meta/packages/clutter/clutter-1.0_git.bb b/meta/packages/clutter/clutter-1.0_git.bb
new file mode 100644 (file)
index 0000000..bfa41cd
--- /dev/null
@@ -0,0 +1,15 @@
+require clutter.inc
+
+PV = "1.0+git${SRCPV}"
+PR = "r0"
+
+PACKAGES =+ "clutter-examples-1.0"
+FILES_clutter-examples-1.0 = "${bindir}/test-* ${pkgdatadir}/redhand.png"
+
+SRC_URI = "git://git.clutter-project.org/clutter.git;protocol=git;branch=clutter-1.0 \
+           file://enable_tests-1.0.patch;patch=1 "
+
+S = "${WORKDIR}/git"
+
+BASE_CONF += "--disable-introspection"
+
diff --git a/meta/packages/clutter/clutter/enable_tests-1.0.patch b/meta/packages/clutter/clutter/enable_tests-1.0.patch
new file mode 100644 (file)
index 0000000..953edf6
--- /dev/null
@@ -0,0 +1,32 @@
+---
+ tests/Makefile.am   |    7 ++++++-
+ tests/test-actors.c |    2 +-
+ tests/test-text.c   |    2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
+
+Index: git/tests/interactive/Makefile.am
+===================================================================
+--- git.orig/tests/interactive/Makefile.am     2009-03-12 11:01:36.000000000 +0000
++++ git/tests/interactive/Makefile.am  2009-03-12 11:04:12.000000000 +0000
+@@ -77,7 +77,7 @@
+ AM_CFLAGS = $(CLUTTER_CFLAGS) $(MAINTAINER_CFLAGS)
+ AM_LDFLAGS = $(CLUTTER_LIBS)
+-noinst_PROGRAMS = test-interactive
++bin_PROGRAMS = test-interactive
+ test_interactive_SOURCES = \
+       test-main.c \
+Index: git/tests/interactive/test-actors.c
+===================================================================
+--- git.orig/tests/interactive/test-actors.c   2009-03-12 11:01:36.000000000 +0000
++++ git/tests/interactive/test-actors.c        2009-03-12 11:06:32.000000000 +0000
+@@ -182,7 +182,7 @@
+   oh->scaler_1 = clutter_behaviour_scale_new (alpha, 0.5, 0.5, 1.0, 1.0);
+   oh->scaler_2 = clutter_behaviour_scale_new (alpha, 1.0, 1.0, 0.5, 0.5);
+-  real_hand = clutter_texture_new_from_file ("redhand.png", &error);
++  real_hand = clutter_texture_new_from_file ("/usr/share/clutter/redhand.png", &error);
+   if (real_hand == NULL)
+     {
+       g_error ("image load failed: %s", error->message);