]> code.ossystems Code Review - openembedded-core.git/commitdiff
grub-efi: Add efi_gop module to payload for physical console support
authorDarren Hart <dvhart@linux.intel.com>
Fri, 16 Dec 2011 06:12:29 +0000 (22:12 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 16 Dec 2011 15:33:44 +0000 (15:33 +0000)
Without the efi_gop module, the GRUB menu would work, but the Linux
kernel messages would not be displayed to the physical console. Adding
efi_gop causes grub to pass the proper information in the boot parameters
pointer such that the Linux kernel can detect and use the EFI framebuffer.

Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-bsp/grub/grub-efi-native_1.99.bb

index 40e618c5998c836a791c20da5b7472de76e02191..c86cf500828244a642be9f3281129bacab36aa48 100644 (file)
@@ -60,7 +60,7 @@ EXTRA_OECONF = "--with-platform=efi --disable-grub-mkfont \
 do_mkimage() {
        ./grub-mkimage -p / -d ./grub-core/ \
                       -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE} \
-                      boot linux fat serial part_msdos normal
+                      boot linux fat serial part_msdos normal efi_gop
 }
 addtask mkimage after do_compile before do_install