--- /dev/null
+# gstreamer: Fix a problem with configure if check has already been built
+# Richard Purdie <rpurdie@linux.intel.com>
+
+diff -urN gstreamer-0.10.29-orig/configure.ac gstreamer-0.10.29/configure.ac
+--- gstreamer-0.10.29-orig/configure.ac 2010-06-26 12:49:27.774930773 +0800
++++ gstreamer-0.10.29/configure.ac 2010-06-26 12:51:12.899200233 +0800
+@@ -543,8 +543,10 @@
+ *) BUILD_CHECK=yes ;;
+ esac
+ ])
++
+ dnl bit of a misnomer, but keep the conditional named like this so we don't
+ dnl have to change too much elsewhere
++HAVE_CHECK=no
+ AM_CONDITIONAL(HAVE_CHECK, test "x$BUILD_CHECK" = "xyes")
+
+ dnl configure the desired buffer alignment
+# Fix crash with gst-inspect
+# Chris Lord <chris@openedhand.com>
+
--- gstreamer-0.10.9/tools/gst-inspect.c.old 2006-09-12 11:56:53.000000000 +0100
+++ gstreamer-0.10.9/tools/gst-inspect.c 2006-09-12 11:57:27.000000000 +0100
@@ -1123,7 +1123,7 @@
+++ /dev/null
-Index: gstreamer-0.10.22/configure.ac
-===================================================================
---- gstreamer-0.10.22.orig/configure.ac 2009-01-19 20:35:32.000000000 +0000
-+++ gstreamer-0.10.22/configure.ac 2009-08-19 16:11:05.000000000 +0100
-@@ -498,13 +498,7 @@
- AC_SUBST(GST_DISABLE_XML_DEFINE)
-
- dnl check for "check", unit testing library/header
--if test "$cross_compiling" != yes; then
-- AM_PATH_CHECK(0.9.2,
-- HAVE_CHECK=yes,
-- HAVE_CHECK=no)
--else
- HAVE_CHECK=no
--fi
- AM_CONDITIONAL(HAVE_CHECK, test "x$HAVE_CHECK" = "xyes")
-
- dnl pkg-config check that for libcheck that works for cross-compiling
+++ /dev/null
----
- po/Makefile.in.in | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
---- gstreamer-0.10.17.orig/po/Makefile.in.in
-+++ gstreamer-0.10.17/po/Makefile.in.in
-@@ -27,12 +27,12 @@ datadir = @datadir@
- localedir = $(datadir)/locale
- gettextsrcdir = $(datadir)/gettext/po
-
- INSTALL = @INSTALL@
- INSTALL_DATA = @INSTALL_DATA@
--MKINSTALLDIRS = @MKINSTALLDIRS@
--mkinstalldirs = $(SHELL) `case "$(MKINSTALLDIRS)" in /*) echo "$(MKINSTALLDIRS)" ;; *) echo "$(top_builddir)/$(MKINSTALLDIRS)" ;; esac`
-+MKINSTALLDIRS = $(top_builddir)/mkinstalldirs
-+mkinstalldirs = $(MKINSTALLDIRS)
-
- GMSGFMT = @GMSGFMT@
- MSGFMT = @MSGFMT@
- XGETTEXT = @XGETTEXT@
- MSGMERGE = msgmerge
LICENSE = "LGPL"
HOMEPAGE = "http://www.gstreamer.net/"
DEPENDS = "glib-2.0 gettext libxml2 bison-native flex-native"
-PR = "r1"
+PR = "r0"
inherit autotools pkgconfig
file://gst-inspect-check-error.patch;patch=1"
EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --with-check=no --disable-examples --disable-tests --disable-valgrind --disable-debug"
-do_configure_prepend() {
- # This m4 file contains nastiness which conflicts with libtool 2.2.2
- rm -f ${S}/common/m4/lib-link.m4 || true
-}
-
#do_compile_prepend () {
# mv ${WORKDIR}/gstregistrybinary.[ch] ${S}/gst/
#}