]> code.ossystems Code Review - openembedded-core.git/commitdiff
meta: bump HASHEQUIV_HASH_VERSION after RPM fix
authorAnuj Mittal <anuj.mittal@intel.com>
Thu, 28 Oct 2021 00:33:20 +0000 (08:33 +0800)
committerAnuj Mittal <anuj.mittal@intel.com>
Mon, 1 Nov 2021 15:18:16 +0000 (23:18 +0800)
ef37fca2f4 fixes issues where PLATFORM tag in RPMs generated
n aarch and x86 hosts are different for noarch RPMs. But, we'd
still need to bump hashequiv version for allarch recipes
to avoid issues because of the RPMs that were incorrectly
generated so reproducibility tests don't fail. Also bump PR
to force rebuilds.

Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
meta/recipes-gnome/hicolor-icon-theme/hicolor-icon-theme_0.17.bb
meta/recipes-graphics/wayland/wayland-protocols_1.20.bb
meta/recipes-graphics/xorg-font/encodings_1.0.5.bb
meta/recipes-kernel/wireless-regdb/wireless-regdb_2021.08.28.bb
meta/recipes-multimedia/alsa/alsa-topology-conf_1.2.4.bb
meta/recipes-multimedia/alsa/alsa-ucm-conf_1.2.4.bb
meta/recipes-sato/pulseaudio-sato/pulseaudio-client-conf-sato_1.bb
meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb
meta/recipes-support/iso-codes/iso-codes_4.6.0.bb

index 74e343052846a5c4f80c39a7203685dd2e6e5b43..d70265ee50510cf3c787122fa6d159f08391912c 100644 (file)
@@ -16,3 +16,7 @@ inherit allarch autotools
 FILES_${PN} += "${datadir}/icons"
 
 BBCLASSEXTEND = "native nativesdk"
+
+# remove at next version upgrade or when output changes
+PR = "r1"
+HASHEQUIV_HASH_VERSION .= ".1"
index 3fb78f658c960d93face7e9da29f6f4dd167ea28..35a46dbb081ce3d5e7167a6c434dcc93d3fce4f1 100644 (file)
@@ -20,3 +20,7 @@ inherit allarch autotools pkgconfig
 
 PACKAGES = "${PN}"
 FILES_${PN} += "${datadir}/pkgconfig/wayland-protocols.pc"
+
+# remove at next version upgrade or when output changes
+PR = "r1"
+HASHEQUIV_HASH_VERSION .= ".1"
index 713fcfb93546a1aa555a3d4ce2e3b0e98aa0a183..02c8cff25d906a2183fb29f84340b600bcca8e31 100644 (file)
@@ -23,3 +23,7 @@ EXTRA_OECONF += "--with-encodingsdir=${datadir}/fonts/X11/encodings"
 # postinst from .inc doesn't apply to this recipe
 pkg_postinst_${PN} () {
 }
+
+# remove at next version upgrade or when output changes
+PR = "r1"
+HASHEQUIV_HASH_VERSION .= ".1"
index 376311804e01e7744e31c6ccb30a032676da2de2..b1cad01a25c3f2bcd6ae1a9331fb73fe5fd89d15 100644 (file)
@@ -41,3 +41,7 @@ do_install_append_class-native() {
 RSUGGESTS_${PN} = "crda"
 
 BBCLASSEXTEND = "native"
+
+# remove at next version upgrade or when output changes
+PR = "r1"
+HASHEQUIV_HASH_VERSION .= ".1"
index 26542fbbbcd9276b78e0115df8e4e0e07220ff84..0d4a30a304af09228e4633e5db12e1d397065232 100644 (file)
@@ -20,3 +20,7 @@ do_install() {
 PACKAGES = "${PN}"
 
 FILES_${PN} = "*"
+
+# remove at next version upgrade or when output changes
+PR = "r1"
+HASHEQUIV_HASH_VERSION .= ".1"
index 32cf41c8fd3932759082b19ba6d04649dca9b4b5..7787dad2681590026fdafe73be77354ee32a2674 100644 (file)
@@ -21,3 +21,7 @@ do_install() {
 PACKAGES = "${PN}"
 
 FILES_${PN} = "*"
+
+# remove at next version upgrade or when output changes
+PR = "r1"
+HASHEQUIV_HASH_VERSION .= ".1"
index e27339fb46297ed7c544ac443df104c2e6cf889e..cfba2074f488677ed693c7f472f6972f568b275e 100644 (file)
@@ -15,3 +15,7 @@ do_install() {
 
 FILES_${PN} = "${sysconfdir}/pulse/client.conf.d/50-sato.conf"
 CONFFILES_${PN} = "${sysconfdir}/pulse/client.conf.d/50-sato.conf"
+
+# remove at next version upgrade or when output changes
+PR = "r1"
+HASHEQUIV_HASH_VERSION .= ".1"
index 28d50960230eeb3b1ceee413d769564ebfc785a1..08d3c3fe19814071054bc0191c4c23e3cbbe59ac 100644 (file)
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384
 
 SRC_URI = "file://shutdown.desktop"
 
-PR = "r1"
+PR = "r2"
 
 S = "${WORKDIR}"
 
@@ -22,3 +22,6 @@ pkg_postinst_${PN} () {
 }
 
 inherit allarch
+
+# remove at next version upgrade or when output changes
+HASHEQUIV_HASH_VERSION .= ".1"
index f915716ce7081c404b892ae556227227dba36541..cd27fb0b70d0c7d8d097c53dce9766c7747de1a9 100644 (file)
@@ -20,3 +20,7 @@ S = "${WORKDIR}/git"
 inherit allarch autotools
 
 FILES_${PN} += "${datadir}/xml/"
+
+# remove at next version upgrade or when output changes
+PR = "r1"
+HASHEQUIV_HASH_VERSION .= ".1"