]> code.ossystems Code Review - openembedded-core.git/commitdiff
grub: disable floating ncurses dependency for GPLv2 version
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Thu, 1 Aug 2013 17:17:59 +0000 (18:17 +0100)
committerSaul Wold <sgw@linux.intel.com>
Fri, 2 Aug 2013 15:01:41 +0000 (08:01 -0700)
A dependency was being added on ncurses conditionally upon whether it
had been built first. Explicitly disable this dependency to stop this
from happening.

Note that grub 2.x does not need this same fix because there ncurses is only
used when building grub-emu, which is only built when the specified
target platform is "emu" which we do not use.

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-bsp/grub/grub_0.97.bb

index 6971193378d9df70a66a7cf418fb0751d4f40e30..38f39121d6a343fa107cd724fba7877f366b22fc 100644 (file)
@@ -26,6 +26,8 @@ inherit autotools
 
 COMPATIBLE_HOST = "i.86.*-linux"
 
+EXTRA_OECONF = "--without-curses"
+
 do_install_append_vmware() {
        mkdir -p ${D}/boot/
        ln -sf ../usr/lib/grub/{$TARGET_ARCH}{$TARGET_VENDOR}/ ${D}/boot/grub