]> code.ossystems Code Review - openembedded-core.git/commitdiff
recipe: add slang from OE
authorKang Kai <kai.kang@windriver.com>
Thu, 3 Mar 2011 04:34:36 +0000 (12:34 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 3 Mar 2011 23:13:33 +0000 (23:13 +0000)
slang is the shared library for the S-Lang extension language,
and required by newt because of LSB command check

Signed-off-by: Kang Kai <kai.kang@windriver.com>
meta/recipes-extended/slang/slang/fix-uclibc.patch [new file with mode: 0644]
meta/recipes-extended/slang/slang_2.2.2.bb [new file with mode: 0644]

diff --git a/meta/recipes-extended/slang/slang/fix-uclibc.patch b/meta/recipes-extended/slang/slang/fix-uclibc.patch
new file mode 100644 (file)
index 0000000..c2b8225
--- /dev/null
@@ -0,0 +1,11 @@
+--- slang-2.1.3.orig/src/slcommon.c    2007-01-10 18:09:07.000000000 +0200
++++ slang-2.1.3.orig/src/slcommon.c    2008-03-19 16:09:09.000000000 +0200
+@@ -191,7 +191,7 @@ 
+    return p;
+ }
+-#if !defined(HAVE_ISSETUGID) && defined(__GLIBC__) && (__GLIBC__ >= 2)
++#if !defined(HAVE_ISSETUGID) && defined(__GLIBC__) && (__GLIBC__ >= 2) && !defined(__UCLIBC__)
+ extern int __libc_enable_secure;
+ # define HAVE___LIBC_ENABLE_SECURE 1
+ #endif
diff --git a/meta/recipes-extended/slang/slang_2.2.2.bb b/meta/recipes-extended/slang/slang_2.2.2.bb
new file mode 100644 (file)
index 0000000..7fe76af
--- /dev/null
@@ -0,0 +1,25 @@
+SUMMARY = "The shared library for the S-Lang extension language"
+
+DESCRIPTION = "S-Lang is an interpreted language and a programming library.  The \
+S-Lang language was designed so that it can be easily embedded into \
+a program to provide the program with a powerful extension language. \
+The S-Lang library, provided in this package, provides the S-Lang \
+extension language.  S-Lang's syntax resembles C, which makes it easy \
+to recode S-Lang procedures in C if you need to."
+
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "pcre"
+PR = "r0"
+
+LICENSE = "GPL Artistic"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
+
+
+SRC_URI = "ftp://space.mit.edu/pub/davis/slang/v2.2/OLD/slang-${PV}.tar.bz2 \
+           file://fix-uclibc.patch"
+
+inherit autotools
+
+SRC_URI[md5sum] = "974437602a781cfe92ab61433dd16d03"
+SRC_URI[sha256sum] = "cfaf8551fa3855f9b0043309bb553ef6d457f931b404df5a6ba6a5a69371fc42"