]> code.ossystems Code Review - openembedded-core.git/commitdiff
conf: Use xf86-input-libinput by default
authorJussi Kukkonen <jussi.kukkonen@intel.com>
Wed, 26 Oct 2016 08:37:38 +0000 (11:37 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 31 Oct 2016 14:23:15 +0000 (14:23 +0000)
Don't install legacy X input drivers for any machines by default,
RRECOMMEND xf86-input-libinput instead.

This is the setup suggested by upstream: install only libinput by
default, but let niche legacy drivers sort higher in configuration
so they get chosen if installed. So the order is:
 evdev < libinput < (synaptics|vmmouse|...)

This also removes vmmouse X driver from the qemu config. If a VMware
virtual mouse device really needs to be supported, we should enable
CONFIG_MOUSE_PS2_VMMOUSE in kernel instead: that is directly supported
by the libinput X driver.

Fixes [YOCTO #10195].

Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/conf/machine/include/qemu.inc
meta/conf/machine/include/x86-base.inc
meta/conf/machine/qemux86-64.conf
meta/conf/machine/qemux86.conf
meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb
meta/recipes-graphics/xorg-xserver/xserver-xorg.inc

index 2bc4dc2db6fb5d09b47dfe32cddff3e689bdce8f..0e4103bad771378259c55ff0955945e28c8434dc 100644 (file)
@@ -6,10 +6,8 @@ PREFERRED_PROVIDER_virtual/libgles2 ?= "mesa"
 
 XSERVER ?= "xserver-xorg \
             ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-driver-swrast xserver-xorg-extension-glx', '', d)} \
-            xf86-input-evdev \
-            xf86-input-mouse \
             xf86-video-fbdev \
-            xf86-input-keyboard"
+            "
 
 MACHINE_FEATURES = "alsa bluetooth usbgadget screen"
 
index 479e89e5484afcbc169cc80b338ce1b43df50a85..40d59577fdb5c1ce3ac6ea0ded56e53b2ed2e3d5 100644 (file)
@@ -26,10 +26,6 @@ PREFERRED_VERSION_linux-yocto ??= "4.8%"
 # XSERVER subcomponents, used to build the XSERVER variable
 #
 XSERVER_X86_BASE = "xserver-xorg \
-           xf86-input-mouse \
-           xf86-input-keyboard \
-           xf86-input-evdev \
-           xf86-input-synaptics \
            "
 
 XSERVER_X86_EXT = " \
index b191ddd3cb577a4b7a22f0cf362941a42d2ca3eb..f2b2aebf9557b4282828427b43e98943a684ff8e 100644 (file)
@@ -18,9 +18,6 @@ SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1"
 
 XSERVER = "xserver-xorg \
            ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-driver-swrast xserver-xorg-extension-glx', '', d)} \
-           xf86-input-vmmouse \
-           xf86-input-keyboard \
-           xf86-input-evdev \
            xf86-video-cirrus \
            xf86-video-fbdev \
            xf86-video-vmware \
index 8555fd6bfe78ff94ed5e777bc4fe167f704bb371..09555ad54871ffd705d9ef12de5d14d0b6d1333e 100644 (file)
@@ -17,9 +17,6 @@ SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1"
 
 XSERVER = "xserver-xorg \
            ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-driver-swrast xserver-xorg-extension-glx', '', d)} \
-           xf86-input-vmmouse \
-           xf86-input-keyboard \
-           xf86-input-evdev \
            xf86-video-cirrus \
            xf86-video-fbdev \
            xf86-video-vmware \
index 6b50028562bede3f07eadf411f92bf9c368b8871..97dcac5f79db19db5603cf56c8623ef3031ff1bf 100644 (file)
@@ -11,7 +11,7 @@ inherit packagegroup distro_features_check
 # rdepends on XSERVER
 REQUIRED_DISTRO_FEATURES = "x11"
 
-XSERVER ?= "xserver-xorg xf86-video-fbdev xf86-input-evdev"
+XSERVER ?= "xserver-xorg xf86-video-fbdev"
 XSERVERCODECS ?= ""
 
 RDEPENDS_${PN} = "\
index 29503b1a537af87fa1b4eda2ed51e6e759cd34b2..269fa6304845c37bf6167670dfcc86061360b3bc 100644 (file)
@@ -71,7 +71,7 @@ PACKAGES =+ "${PN}-sdl \
 SUMMARY_xf86-video-modesetting = "X.Org X server -- modesetting display driver"
 INSANE_SKIP_${MLPREFIX}xf86-video-modesetting = "xorg-driver-abi"
 
-XSERVER_RRECOMMENDS = "xkeyboard-config rgb xserver-xf86-config xkbcomp"
+XSERVER_RRECOMMENDS = "xkeyboard-config rgb xserver-xf86-config xkbcomp xf86-input-libinput"
 RRECOMMENDS_${PN} += "${XSERVER_RRECOMMENDS}"
 RRECOMMENDS_${PN}-xwayland += "${XSERVER_RRECOMMENDS}"
 RDEPENDS_${PN}-xvfb += "xkeyboard-config"