]> code.ossystems Code Review - openembedded-core.git/commitdiff
netbase: Disable networkmanager control of eth0 on omap sdp/ldp boards
authorRichard Purdie <richard@openedhand.com>
Fri, 18 Jul 2008 10:01:03 +0000 (10:01 +0000)
committerRichard Purdie <richard@openedhand.com>
Fri, 18 Jul 2008 10:01:03 +0000 (10:01 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4872 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/netbase/netbase_4.21.bb

index c629da1d74a071c9e05e4817f670b8af5263136f..72a4d937df11618727779db85f66b0406f9f6ca8 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "This package provides the necessary \
 infrastructure for basic TCP/IP based networking."
 SECTION = "base"
 LICENSE = "GPL"
-PR = "r18"
+PR = "r20"
 
 inherit update-rc.d
 
@@ -37,13 +37,19 @@ do_install () {
        install -m 0755 update-inetd ${D}${sbindir}/
        install -m 0644 update-inetd.8 ${D}${mandir}/man8/
        install -m 0644 ${WORKDIR}/interfaces ${D}${sysconfdir}/network/interfaces
-       
+
        # Disable network manager on machines that commonly do NFS booting
-       if [ "${MACHINE}" = "omap-3430ldp" ]; then
-               touch ${D}${sysconfdir}/network/nm-disabled-eth0
-       fi
+       case "${MACHINE}" in
+               "omap-3430sdp" | "omap-3430ldp" | "omap-2430sdp")
+                       touch ${D}${sysconfdir}/network/nm-disabled-eth0
+                       ;;
+               *)
+                       ;;
+       esac
 }
 
 CONFFILES_${PN} = "${sysconfdir}/network/options ${sysconfdir}/hosts ${sysconfdir}/network/interfaces"
 
+PACKAGE_ARCH_omap-3430sdp = "${MACHINE_ARCH}"
 PACKAGE_ARCH_omap-3430ldp = "${MACHINE_ARCH}"
+PACKAGE_ARCH_omap-2430sdp = "${MACHINE_ARCH}"