]> code.ossystems Code Review - openembedded-core.git/commitdiff
gcc(-cross): move zecke-no-host-includes.patch only to cross version
authorMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 12 Apr 2007 10:03:29 +0000 (10:03 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 12 Apr 2007 10:03:29 +0000 (10:03 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1482 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/gcc/gcc-cross_4.1.1.bb
meta/packages/gcc/gcc_4.1.1.bb

index 42e9d151b188e95c958656bea22aa6bf9f83a0db..62499f8ee6223fe4816525279b7acab8c09849a8 100644 (file)
@@ -5,7 +5,7 @@ inherit cross
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
 # NOTE: split PR.  If the main .oe changes something that affects its *build*
 # remember to increment this one too.
-PR = "r11"
+PR = "r12"
 
 DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
 PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
@@ -16,3 +16,5 @@ require gcc3-build-cross.inc
 require gcc-package-cross.inc
 
 EXTRA_OECONF += "--with-mpfr=${STAGING_DIR}/${BUILD_SYS}"
+
+SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
index e32353325ac26ad313f3cc40de76ca04f66f3110..ea99e8bcba4714c88fb7ce514d7a45b33cc56a90 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r9"
+PR = "r10"
 DESCRIPTION = "The GNU cc and gcc C compilers."
 HOMEPAGE = "http://www.gnu.org/software/gcc/"
 SECTION = "devel"
@@ -31,10 +31,9 @@ SRC_URI = "http://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.1/gcc-4.1.1.tar.bz2 \
        file://unbreak-armv4t.patch;patch=1 \
         file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
         file://gcc-4.1.1-pr13685-1.patch;patch=1 \
+        file://gcc-ignore-cache.patch;patch=1 \
        "
 
-SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
-
 #Set the fortran bits
 # 'fortran' or '', not 'f77' like gcc3 had 
 FORTRAN = ""