]> code.ossystems Code Review - openembedded-core.git/commitdiff
opkg/dpkg: remove the postinstalls
authorLaurentiu Palcu <laurentiu.palcu@intel.com>
Thu, 6 Mar 2014 12:15:42 +0000 (14:15 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 7 Mar 2014 15:04:36 +0000 (15:04 +0000)
Just use the run-postinsts recipe for running first boot postinstalls.

[YOCTO #5666]

Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/dpkg/dpkg.inc
meta/recipes-devtools/opkg/opkg.inc

index 471151ed3b0fef26692af8cfcc3e74a2ddf2c445..eef7ce9d40ee40124183ec46ca4ebfe3072530f5 100644 (file)
@@ -7,7 +7,7 @@ SRC_URI = "${DEBIAN_MIRROR}/main/d/dpkg/dpkg_${PV}.tar.xz \
 
 DEPENDS = "zlib bzip2 perl ncurses"
 DEPENDS_class-native = "bzip2-replacement-native zlib-native virtual/update-alternatives-native gettext-native perl-native"
-RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} xz"
+RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} xz run-postinsts"
 RDEPENDS_${PN}_class-native = "xz-native"
 
 S = "${WORKDIR}/${BPN}-${PV}"
@@ -43,8 +43,6 @@ do_configure () {
     autotools_do_configure
 }
 
-DPKG_INIT_POSITION ?= "98"
-
 do_install_append () {
        if [ "${PN}" = "dpkg-native" ]; then
                # update-alternatives doesn't have an offline mode
@@ -66,26 +64,6 @@ do_install_append () {
        fi
 }
 
-pkg_postinst_${PN} () {
-#!/bin/sh
-if ${@base_contains('DISTRO_FEATURES','sysvinit','true','false',d)} && \
-       [ "x$D" != "x" ] && [ -f $D/var/lib/dpkg/status ]; then
-       install -d $D${sysconfdir}/rcS.d
-
-       # this happens at S98 where our good 'ole packages script used to run
-       echo "#!/bin/sh
-[ -e ${sysconfdir}/default/postinst ] && . ${sysconfdir}/default/postinst
-if [ \"\$POSTINST_LOGGING\" = \"1\" ]; then
-    dpkg --configure -a >\$LOGFILE 2>&1
-else
-    dpkg --configure -a
-fi
-rm -f ${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}run-postinsts
-" > $D${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}run-postinsts
-       chmod 0755 $D${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}run-postinsts
-fi
-}
-
 PROV = "virtual/update-alternatives"
 PROV_class-native = ""
 
index 7bea26d42c48ac88525ede217aabef68b7c3e295..9f87df551ebf6a7fedc43b7d60b9cc218f77a210 100644 (file)
@@ -38,7 +38,7 @@ EXTRA_OECONF = "\
   --with-opkglibdir=${OPKGLIBDIR} \
 "
 
-RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-config-base"
+RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-config-base run-postinsts"
 RDEPENDS_${PN}_class-native = ""
 RDEPENDS_${PN}_class-nativesdk = ""
 RREPLACES_${PN} = "opkg-nogpg"
@@ -73,30 +73,4 @@ do_install_append() {
        rm ${D}${bindir}/update-alternatives
 }
 
-pkg_postinst_${PN} () {
-#!/bin/sh
-if ${@base_contains('DISTRO_FEATURES','sysvinit','true','false',d)} && \
-       [ "x$D" != "x" ] && [ -f $D${OPKGLIBDIR}/opkg/status ]; then
-       install -d $D${sysconfdir}/rcS.d
-
-       # this happens at S98 where our good 'ole packages script used to run
-       echo "#!/bin/sh
-[ -e ${sysconfdir}/default/postinst ] && . ${sysconfdir}/default/postinst
-if [ \"\$POSTINST_LOGGING\" = \"1\" ]; then
-    opkg-cl configure >\$LOGFILE 2>&1
-else
-    opkg-cl configure
-fi
-rm -f ${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}run-postinsts
-" > $D${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}run-postinsts
-       chmod 0755 $D${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}run-postinsts
-fi
-}
-
 BBCLASSEXTEND = "native nativesdk"
-
-# Define a variable to allow distros to run configure earlier.
-# (for example, to enable loading of ethernet kernel modules before networking starts)
-# note: modifying name or default value for POSTINSTALL_INITPOSITION requires
-# changes in systemd-compat-units.bb
-POSTINSTALL_INITPOSITION ?= "98"