]> code.ossystems Code Review - openembedded-core.git/commitdiff
pseudo: Abort on mismatch patch
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 29 Sep 2020 16:57:38 +0000 (17:57 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 7 Oct 2020 10:18:35 +0000 (11:18 +0100)
Rather than doing what turns out to be a rather dangerous "fixup" if
we see a file with a different path but the same inode as another file
we've previously seen, throw and abort. Direct the user to a wiki page
where we can maintain information about what this error means.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/pseudo/files/abort_on_mismatch.patch [new file with mode: 0644]
meta/recipes-devtools/pseudo/pseudo_git.bb

diff --git a/meta/recipes-devtools/pseudo/files/abort_on_mismatch.patch b/meta/recipes-devtools/pseudo/files/abort_on_mismatch.patch
new file mode 100644 (file)
index 0000000..1737269
--- /dev/null
@@ -0,0 +1,64 @@
+Rather than mapping mismatched inode entries to paths, thrown an abort() 
+instead. Add a new result type to allow the server to pass back
+this instruction to the client.
+
+Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
+Upstream-Status: Pending
+
+Index: git/pseudo.c
+===================================================================
+--- git.orig/pseudo.c
++++ git/pseudo.c
+@@ -695,17 +695,15 @@ pseudo_op(pseudo_msg_t *msg, const char
+                                               msg->path);
+                                       pdb_did_unlink_file(path_by_ino, &by_ino, by_ino.deleting);
+                               } else {
+-                                      int flags = 0;
+-                                      if (msg->nlink > 1) {
+-                                              flags = PDBGF_FILE | PDBGF_VERBOSE;
+-                                      }
+-                                      pseudo_debug(flags, "path mismatch [%d link%s]: ino %llu db '%s' req '%s'.\n",
++                                      pseudo_diag("path mismatch [%d link%s]: ino %llu db '%s' req '%s'.\n",
+                                               msg->nlink,
+                                               msg->nlink == 1 ? "" : "s",
+                                               (unsigned long long) msg_header.ino,
+                                               path_by_ino ? path_by_ino : "no path",
+                                               msg->path);
+                                       found_ino = 0;
++                                      msg->result = RESULT_ABORT;
++                                      goto op_exit;
+                               }
+                       }
+               } else {
+@@ -1025,6 +1023,7 @@ pseudo_op(pseudo_msg_t *msg, const char
+               break;
+       }
++op_exit:
+       /* in the case of an exact match, we just used the pointer
+        * rather than allocating space.
+        */
+Index: git/pseudo_client.c
+===================================================================
+--- git.orig/pseudo_client.c
++++ git/pseudo_client.c
+@@ -1919,6 +1919,10 @@ pseudo_client_op(pseudo_op_t op, int acc
+ #endif
+               if (result) {
+                       pseudo_debug(PDBGF_OP, "(%d) %s", getpid(), pseudo_res_name(result->result));
++                      if (result->result == RESULT_ABORT) {
++                              pseudo_diag("abort()ing pseudi client by server request. See https://wiki.yoctoproject.org/wiki/Pseudo_Abort for more details on this.\n");
++                              abort();
++                      }
+                       if (op == OP_STAT || op == OP_FSTAT) {
+                               pseudo_debug(PDBGF_OP, " mode 0%o uid %d:%d",
+                                       (int) result->mode,
+Index: git/enums/res.in
+===================================================================
+--- git.orig/enums/res.in
++++ git/enums/res.in
+@@ -2,3 +2,4 @@ res: RESULT
+ succeed
+ fail
+ error
++abort
index 57c32d0cfc180b3d6db1dcc45c5ace99d141039d..56c9b4e2328bc7e2079a545a1630251aff53e194 100644 (file)
@@ -4,6 +4,7 @@ SRC_URI = "git://git.yoctoproject.org/pseudo;branch=oe-core \
            file://0001-configure-Prune-PIE-flags.patch \
            file://delete_mismatches.patch \
            file://add_ignore_paths.patch \
+           file://abort_on_mismatch.patch \
            file://fallback-passwd \
            file://fallback-group \
            "