]> code.ossystems Code Review - openembedded-core.git/commitdiff
glibc/eglibc: Clean up package warnings and potentially broken data in -dev package
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 29 Jun 2011 12:35:00 +0000 (13:35 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 29 Jun 2011 13:27:50 +0000 (14:27 +0100)
These changes ensure files packaged in the -locale package aren't included
in the main do_install and also ensures the staging directory used for
the -locale package doesn't end up in the -dev package.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/eglibc/eglibc-package.inc
meta/recipes-core/eglibc/eglibc_2.12.bb
meta/recipes-core/eglibc/eglibc_2.13.bb
meta/recipes-core/glibc/glibc-package.inc
meta/recipes-core/glibc/glibc_2.10.1.bb

index 8228484815ba9e0860daa18f65ade80e4d86ee2c..831835612ec5a4b6d006209247f59c5a389ced98 100644 (file)
@@ -90,13 +90,21 @@ inherit libc-common
 
 do_install_locale () {
        dest=${D}/${includedir}/eglibc-locale-internal-${MULTIMACH_TARGET_SYS}
-       install -d ${dest} ${dest}${bindir}
-       cp -fpPR ${D}${base_libdir} ${dest}${base_prefix}
-       cp -fpPR ${D}${libdir} ${dest}${exec_prefix}
-       cp -fpPR ${D}${datadir} ${dest}${exec_prefix}
-       cp -fpPR ${D}${bindir}/localedef ${dest}${bindir}
+       install -d ${dest}${base_libdir} ${dest}${bindir} ${dest}${libdir} ${dest}${datadir}
+       cp -fpPR ${D}${base_libdir}/* ${dest}${base_libdir}
+       cp -fpP ${D}${bindir}/localedef ${dest}${bindir}
+        mv ${D}${libdir}/gconv ${dest}${libdir}
+       cp -fpPR ${D}${libdir}/* ${dest}${libdir}
+        mv ${D}${datadir}/i18n ${dest}${datadir}
+       cp -fpPR ${D}${datadir}/* ${dest}${datadir}
        cp -fpPR ${WORKDIR}/SUPPORTED ${dest}
 }
 
 addtask do_install_locale after do_install before do_populate_sysroot
 
+PACKAGE_PREPROCESS_FUNCS += "eglibc_package_preprocess"
+
+eglibc_package_preprocess () {
+       rm -rf ${PKGD}/${includedir}/eglibc-locale-internal-${MULTIMACH_TARGET_SYS}
+}
+
index 47b1822ac6df2e7e2a1495ae1edebef03495a21e..60358e1791ab85271be08dc8ceed74d753edbaf6 100644 (file)
@@ -1,7 +1,7 @@
 require eglibc.inc
 
 DEPENDS += "gperf-native"
-PR = "r16"
+PR = "r17"
 
 SRCREV = "14158"
 
index dfedfef9d92e5fbd7ce6b03aeb15f6a715b70a04..50880496f64fcc8bba6358fbe783ef33d435e485 100644 (file)
@@ -4,7 +4,7 @@ SRCREV = "14157"
 
 DEPENDS += "gperf-native"
 FILESPATHPKG =. "eglibc-svn:"
-PR = "r3"
+PR = "r4"
 PR_append = "+svnr${SRCPV}"
 
 EGLIBC_BRANCH="eglibc-2_13"
index 5373d56d57eeb9c5afa9653a30aeadb74f0fd358..c1c38534b78d66fa5ece19c6af865f3a310a4503 100644 (file)
@@ -74,3 +74,23 @@ EXTRA_OEMAKE += "rootsbindir=${base_sbindir}"
 
 inherit libc-common
 
+do_install_locale () {
+       dest=${D}/${includedir}/glibc-locale-internal-${MULTIMACH_TARGET_SYS}
+       install -d ${dest}${base_libdir} ${dest}${bindir} ${dest}${libdir} ${dest}${datadir}
+       cp -fpPR ${D}${base_libdir}/* ${dest}${base_libdir}
+       cp -fpP ${D}${bindir}/localedef ${dest}${bindir}
+        mv ${D}${libdir}/gconv ${dest}${libdir}
+       cp -fpPR ${D}${libdir}/* ${dest}${libdir}
+        mv ${D}${datadir}/i18n ${dest}${datadir}
+       cp -fpPR ${D}${datadir}/* ${dest}${datadir}
+       cp -fpPR ${WORKDIR}/SUPPORTED ${dest}
+}
+
+addtask do_install_locale after do_install before do_populate_sysroot
+
+PACKAGE_PREPROCESS_FUNCS += "glibc_package_preprocess"
+
+glibc_package_preprocess () {
+       rm -rf ${PKGD}/${includedir}/eglibc-locale-internal-${MULTIMACH_TARGET_SYS}
+}
+
index 4d57c4ed3222f3ab644743c00149da95fb3490fe..e76f3c01948874980e520b906650fed3dd7582d0 100644 (file)
@@ -154,18 +154,6 @@ do_compile () {
        )
 }
 
-do_install_locale () {
-       dest=${D}/${includedir}/glibc-locale-internal-${MULTIMACH_TARGET_SYS}
-       install -d ${dest} ${dest}${bindir}
-       cp -fpPR ${D}${base_libdir} ${dest}${base_prefix}
-       cp -fpPR ${D}${libdir} ${dest}${exec_prefix}
-       cp -fpPR ${D}${datadir} ${dest}${exec_prefix}
-       cp -fpPR ${D}${bindir}/localedef ${dest}${bindir}
-       cp -fpPR ${WORKDIR}/SUPPORTED ${dest}
-}
-
-addtask do_install_locale after do_install before do_populate_sysroot
-
 require glibc-stage.inc
 
 require glibc-package.inc