]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: Fix build on ppc
authorKhem Raj <raj.khem@gmail.com>
Wed, 23 Jan 2013 02:45:00 +0000 (18:45 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 24 Jan 2013 20:08:00 +0000 (20:08 +0000)
ppc discovers an interesting issue in linking systemd where a library is
missing in link cmdline and linker barfs

./.libs/libsystemd-core.a(libsystemd_core_la-manager.o): In function
`manager_check_finished':
/builddir/build/BUILD/systemd-196/src/core/manager.c:2092: undefined
reference to `sd_notifyf'
collect2: error: ld returned 1 exit status

For more info see

https://bugzilla.redhat.com/show_bug.cgi?id=888255

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/systemd/systemd/0001-test-unit-file-Add-libsystemd-daemon.la-to-LDADD.patch [new file with mode: 0644]
meta/recipes-core/systemd/systemd_196.bb

diff --git a/meta/recipes-core/systemd/systemd/0001-test-unit-file-Add-libsystemd-daemon.la-to-LDADD.patch b/meta/recipes-core/systemd/systemd/0001-test-unit-file-Add-libsystemd-daemon.la-to-LDADD.patch
new file mode 100644 (file)
index 0000000..4cd2ee6
--- /dev/null
@@ -0,0 +1,32 @@
+Upstream-Status: Submitted
+
+From f3e0a95b6b3fe516e43ec72045c2fad239184392 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 22 Jan 2013 18:25:46 -0800
+Subject: [PATCH] test-unit-file: Add libsystemd-daemon.la to LDADD
+
+test-unit-file links with libsystemd-core which needs
+sd_* symbols from libsystemd-daemon
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Makefile.am |    3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 7d5bd5a..884227a 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1270,7 +1270,8 @@ test_unit_file_CFLAGS = \
+       $(DBUS_CFLAGS)
+ test_unit_file_LDADD = \
+-      libsystemd-core.la
++      libsystemd-core.la \
++      libsystemd-daemon.la
+ test_log_SOURCES = \
+       src/test/test-log.c
+-- 
+1.7.9.5
+
index a78a8a6c5bee666ebdb9e796ea0060871dc0f56a..9801fc567ea0578a4b659f4dc61956e5dff1085d 100644 (file)
@@ -8,6 +8,8 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe \
 
 PROVIDES = "udev"
 
+PR = "r1"
+
 DEPENDS = "xz kmod docbook-sgml-dtd-4.1-native intltool-native gperf-native acl readline dbus libcap libcgroup tcp-wrappers usbutils glib-2.0 libgcrypt"
 DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
 
@@ -23,6 +25,7 @@ SRC_URI = "http://www.freedesktop.org/software/systemd/systemd-${PV}.tar.xz \
            file://var-run.conf \
            ${UCLIBCPATCHES} \
            file://00-create-volatile.conf \
+           file://0001-test-unit-file-Add-libsystemd-daemon.la-to-LDADD.patch \
           "
 SRC_URI[md5sum] = "05ebd7f108e420e2b4e4810ea4b3c810"
 SRC_URI[sha256sum] = "6bd4a658a5dd8198235b17ad1b1f0cc56d9e6f00d646ddcffdfc6f058b55e4bf"