]> code.ossystems Code Review - openembedded-core.git/commitdiff
busybox: unbreak tar of uncompressed files
authorSaul Wold <sgw@linux.intel.com>
Tue, 28 Apr 2015 22:46:04 +0000 (15:46 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 29 Apr 2015 16:53:06 +0000 (17:53 +0100)
A patch was added to fix compressed tar files, but broke uncompressed
tar files, this fix is from the busybox mailing list

http://lists.busybox.net/pipermail/busybox/2014-January/080389.html

[YOCTO #7645]

Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/busybox/busybox/unbreak_noncompressed_tar.patch [new file with mode: 0644]
meta/recipes-core/busybox/busybox_1.22.1.bb

diff --git a/meta/recipes-core/busybox/busybox/unbreak_noncompressed_tar.patch b/meta/recipes-core/busybox/busybox/unbreak_noncompressed_tar.patch
new file mode 100644 (file)
index 0000000..3c3c23a
--- /dev/null
@@ -0,0 +1,23 @@
+
+This patch allows tar to continue correctly when it does not detect
+a compressed format. This allows tar to then untar a non-compressed 
+tar file.
+
+See this thread for details: http://lists.busybox.net/pipermail/busybox/2014-January/080389.html
+
+Upstream-Status: Inappropriate [Upstream has different fix with additional functionality]
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+Index: busybox-1.22.1/archival/libarchive/open_transformer.c
+===================================================================
+--- busybox-1.22.1.orig/archival/libarchive/open_transformer.c
++++ busybox-1.22.1/archival/libarchive/open_transformer.c
+@@ -200,7 +200,7 @@ int FAST_FUNC open_zipped(const char *fn
+        || (ENABLE_FEATURE_SEAMLESS_BZ2)
+        || (ENABLE_FEATURE_SEAMLESS_XZ)
+       ) {
+-              setup_unzip_on_fd(fd, /*fail_if_not_detected:*/ 1);
++              setup_unzip_on_fd(fd, /*fail_if_not_detected:*/ 0);
+       }
+       return fd;
index ae8eca70ff7f0efefc6f5b6f03e8aafb2cfb1b16..1b1eaf35ac6bf3753a09c0c76354ce5bc1d75012 100644 (file)
@@ -35,6 +35,7 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
            file://CVE-2014-9645_busybox_reject_module_names_with_slashes.patch \
            file://lzop-add-overflow-check.patch \
            file://libarchive-open_zipped-does-not-need-to-check-extens.patch \
+           file://unbreak_noncompressed_tar.patch \
 "
 
 SRC_URI[tarball.md5sum] = "337d1a15ab1cb1d4ed423168b1eb7d7e"