]> code.ossystems Code Review - openembedded-core.git/commitdiff
matchbox-keyboard: use the gtk-immodules-cache.bbclass
authorLaurentiu Palcu <laurentiu.palcu@intel.com>
Thu, 20 Dec 2012 13:15:40 +0000 (15:15 +0200)
committerSaul Wold <sgw@linux.intel.com>
Thu, 10 Jan 2013 00:40:38 +0000 (16:40 -0800)
Since the class was already present, use it. Also, this will have the
postinstalls run on host, at do_rootfs time.

[YOCTO #3602]

Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb

index adde25bcf0f046ceccf191cef198453d541750fd..a7091d25195a9442d55c3dc3c1842b4ebcc2cc19 100644 (file)
@@ -22,7 +22,7 @@ SRC_URI = "git://git.yoctoproject.org/${BPN};protocol=git \
 
 S = "${WORKDIR}/git"
 
-inherit autotools pkgconfig gettext
+inherit autotools pkgconfig gettext gtk-immodules-cache
 
 EXTRA_OECONF = "--disable-cairo --enable-gtk-im --enable-applet"
 
@@ -49,18 +49,4 @@ do_install_append () {
        rm -f ${D}${libdir}/matchbox-panel/*.la
 }
 
-pkg_postinst_matchbox-keyboard-im () {
-if [ "x$D" != "x" ]; then
-  exit 1
-fi
-
-gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
-}
-
-pkg_postrm_matchbox-keyboard-im () {
-if [ "x$D" != "x" ]; then
-  exit 1
-fi
-
-gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
-}
+GTKIMMODULES_PACKAGES = "${PN}-im"