]> code.ossystems Code Review - openembedded-core.git/commitdiff
u-boot.inc: fix compilation when using 'gold' as linker
authorOtavio Salvador <otavio@ossystems.com.br>
Sun, 22 Apr 2012 18:01:32 +0000 (15:01 -0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 24 Apr 2012 14:51:36 +0000 (15:51 +0100)
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
meta/recipes-bsp/u-boot/u-boot.inc

index 0445c343d35399eb3627536863ea54ce2a86847b..a13eddc829962cc22bb6792a5696ead95a9a607f 100644 (file)
@@ -36,6 +36,10 @@ SPL_IMAGE ?= "${SPL_BINARY}-${MACHINE}-${PV}-${PR}"
 SPL_SYMLINK ?= "${SPL_BINARY}-${MACHINE}"
 
 do_compile () {
+       if [ "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then
+               sed -i 's/$(CROSS_COMPILE)ld/$(CROSS_COMPILE)ld.bfd/g' config.mk
+       fi
+
        unset LDFLAGS
        unset CFLAGS
        unset CPPFLAGS