]> code.ossystems Code Review - openembedded-core.git/commitdiff
strace: Don't package strace-graph
authorPhil Blundell <philb@gnu.org>
Wed, 26 Sep 2012 10:18:29 +0000 (11:18 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 18 Oct 2012 11:00:36 +0000 (12:00 +0100)
Commit 9c9ea24b115a9bb87df1323b5f185ce426262aec made strace depend on perl because the
strace-graph script needs it.  However, this cost of the dependency is large (building
all of perl) and the value of the script is marginal.  Let's just delete the script
instead and remove the dependency again.

If anybody wants strace-graph then it should be packaged in its own recipe and that one
can be made to depend on perl without disrupting the main strace package.

Signed-off-by: Phil Blundell <pb@pbcl.net>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/strace/strace_4.7.bb

index 21dd47a811b87cd7c4e0b3191cf3b6c6e23ff9d2..e1a5e828ed4c1db86b33055f5cfc52303b6eeedb 100644 (file)
@@ -3,11 +3,7 @@ HOMEPAGE = "http://strace.sourceforge.net"
 SECTION = "console/utils"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=124500c21e856f0912df29295ba104c7"
-PR = "r1"
-
-PACKAGES =+ "${PN}-graph "
-FILES_${PN}-graph = "${bindir}/strace-graph"
-RDEPENDS_${PN}-graph = "perl"
+PR = "r2"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
            file://strace-eglibc-2.16.patch \
@@ -20,4 +16,9 @@ inherit autotools
 
 export INCLUDES = "-I. -I./linux"
 
+do_install_append() {
+       # We don't ship strace-graph here because it needs perl
+       rm ${D}${bindir}/strace-graph
+}
+
 BBCLASSEXTEND = "native"