]> code.ossystems Code Review - openembedded-core.git/commitdiff
Disable wget server side cache
authorLiping Ke <liping.ke@intel.com>
Thu, 10 Mar 2011 09:27:55 +0000 (17:27 +0800)
committerSaul Wold <sgw@linux.intel.com>
Fri, 11 Mar 2011 01:10:51 +0000 (17:10 -0800)
We found some proxy server has wrong cache for long http file name.
It will cause fetching wrong ipk files from adt repo. To avoid this,
we use wget options --no-cache to disable all server side cache.
It will make the fetch speed slower, yet correct always.

Signed-off-by: Liping Ke <liping.ke@intel.com>
Signed-off-by: Lianhao Lu <lianhao.lu@intel.com>
meta/recipes-devtools/installer/adt-installer_1.0.bb
meta/recipes-devtools/installer/files/wget_cache.patch [new file with mode: 0644]

index 50290f9ffd1fb06e9167978b9cbff88460ca0fdb..ff7afe6623ff3d25a99b1126fafdb0678aa269ad 100644 (file)
@@ -36,11 +36,13 @@ PR = "r0"
 ADT_DEPLOY = "${TMPDIR}/deploy/sdk/"
 ADT_DIR = "${WORKDIR}/adt-installer/"
 YOCTOADT_VERSION = "${SDK_VERSION}"
+S = "${WORKDIR}/trunk"
 
 inherit deploy
 
 PV = "0.1.8+svnr${SRCPV}"
 SRC_URI = "svn://opkg.googlecode.com/svn;module=trunk;proto=http \
+           file://wget_cache.patch \
            file://adt_installer \
            file://scripts/adt_installer_internal \
            file://scripts/util \
@@ -70,7 +72,6 @@ fakeroot do_deploy () {
        cp ${WORKDIR}/adt_installer.tar.bz2 ${ADT_DEPLOY}
 }
 
-do_patch[noexec] = "1"
 do_install[noexec] = "1"
 do_configure[noexec] = "1"
 do_compile[noexec] = "1"
diff --git a/meta/recipes-devtools/installer/files/wget_cache.patch b/meta/recipes-devtools/installer/files/wget_cache.patch
new file mode 100644 (file)
index 0000000..6fd38e5
--- /dev/null
@@ -0,0 +1,10 @@
+--- trunk/libopkg/opkg_download.c      2011-03-10 16:41:29.000000000 +0800
++++ trunk/libopkg/opkg_download.c      2011-03-10 16:42:33.000000000 +0800
+@@ -162,6 +162,7 @@
+       argv[i++] = "wget";
+       argv[i++] = "-q";
++      argv[i++] = "--no-cache";
+       if (conf->http_proxy || conf->ftp_proxy) {
+       argv[i++] = "-Y";
+       argv[i++] = "on";