]> code.ossystems Code Review - openembedded-core.git/commitdiff
base-files: move hostname operations out of issue file settings
authorChen Qi <Qi.Chen@windriver.com>
Wed, 17 Apr 2019 02:01:25 +0000 (10:01 +0800)
committerArmin Kuster <akuster808@gmail.com>
Thu, 2 May 2019 20:24:26 +0000 (13:24 -0700)
The function do_install_basefilesissue is meant to deal with
/etc/issue* files and the following setting could actually be
overridden.

  BASEFILESISSUEINSTALL ?= "do_install_basefilesissue"

So move the hostname operations out of this function.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-core/base-files/base-files_3.0.14.bb

index a1639db830362b18939ece67578a9425becdec94..4b4027f18d7586afe01db8c05460d27904c5f938 100644 (file)
@@ -134,15 +134,16 @@ do_install () {
        install -m 0644 ${WORKDIR}/motd ${D}${sysconfdir}/motd
 
        ln -sf /proc/mounts ${D}${sysconfdir}/mtab
-}
 
-DISTRO_VERSION[vardepsexclude] += "DATE"
-do_install_basefilesissue () {
+       # deal with hostname
        if [ "${hostname}" ]; then
                echo ${hostname} > ${D}${sysconfdir}/hostname
                echo "127.0.1.1 ${hostname}" >> ${D}${sysconfdir}/hosts
        fi
+}
 
+DISTRO_VERSION[vardepsexclude] += "DATE"
+do_install_basefilesissue () {
        install -m 644 ${WORKDIR}/issue*  ${D}${sysconfdir}
         if [ -n "${DISTRO_NAME}" ]; then
                printf "${DISTRO_NAME} " >> ${D}${sysconfdir}/issue