]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: avoid musl specific patches affect glibc systems
authorChen Qi <Qi.Chen@windriver.com>
Fri, 7 Jun 2019 20:26:39 +0000 (23:26 +0300)
committerArmin Kuster <akuster808@gmail.com>
Fri, 14 Jun 2019 14:05:34 +0000 (07:05 -0700)
systemd upstream only care about glibc. We made musl specific
patches so that systemd could work. But currently these patches
contain potential security issues.

So apply these patches only when the libc is musl.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Adrian Bunk <bunk@stusta.de>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-core/systemd/systemd_241.bb

index 3a58f44a3bd45b77d4af1ef5d85fd2e9b362cd78..eb3242d6244854f944b2d6c8701c3a2693ba236c 100644 (file)
@@ -27,7 +27,7 @@ SRC_URI += "file://touchscreen.rules \
            "
 
 # patches needed by musl
-SRC_URI += "${SRC_URI_MUSL}"
+SRC_URI_append_libc-musl = " ${SRC_URI_MUSL}"
 SRC_URI_MUSL = "file://0001-Use-getenv-when-secure-versions-are-not-available.patch \
                file://0002-don-t-use-glibc-specific-qsort_r.patch \
                file://0003-missing_type.h-add-__compare_fn_t-and-comparison_fn_.patch \