]> code.ossystems Code Review - openembedded-core.git/commitdiff
gcc/libtool/perl: Fix various path to sed-native problems
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 25 Sep 2013 12:36:00 +0000 (12:36 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 26 Sep 2013 15:37:14 +0000 (16:37 +0100)
If sed-native is built before these programs, hardcoded paths to sed-native
can end up in scripts and other parts of the system which may cause issues
if they are later used from sstate and sed-native is not installed.

To avoid this, this patch changes the global site configuration to
specify that plain "sed" is fine to be used. We need to spell this
out for gcc since it doesn't see the site files since we don't autoreconf
it. We can remove the values from libtool. We tell perl to use "/bin/sed"
since it requires a path and the system sed should be just fine for it.

[YOCTO #4971]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/gcc/gcc-configure-common.inc
meta/recipes-devtools/libtool/libtool-2.4.2.inc
meta/recipes-devtools/libtool/libtool-native_2.4.2.bb
meta/recipes-devtools/perl/perl-native_5.14.3.bb
meta/site/common

index b87ea62570ec968421c6a278563a4f6640586237..dc44cc9f084ddb1ef77764a1dde6e4bef8b25ec9 100644 (file)
@@ -48,6 +48,7 @@ EXTRA_OECONF = "${@['--enable-clocale=generic', ''][d.getVar('USE_NLS', True) !=
                 ${@get_gcc_mips_plt_setting(bb, d)} \
                 ${@get_gcc_multiarch_setting(bb, d)}"
 
+export ac_cv_path_SED = 'sed'
 export gcc_cv_collect2_libs = 'none required'
 # We need to set gcc_cv_collect2_libs else there is cross-compilation badness
 # in the config.log files (which might not get generated until do_compile
index 92e49499dd30e6e39272c3bd2ba8026eba0f489b..5a67eeb9d183daafd057dcada3c7c8bd9ed80363 100644 (file)
@@ -26,9 +26,6 @@ SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
 SRC_URI[md5sum] = "d2f3b7d4627e69e13514a40e72a24d50"
 SRC_URI[sha256sum] = "b38de44862a987293cd3d8dfae1c409d514b6c4e794ebc93648febf9afc38918"
 
-# Don't want paths to sed-native (or anything else) encoded
-CACHED_CONFIGUREVARS += "ac_cv_path_SED=sed"
-
 do_compile_prepend () {
        # Sometimes this file doesn't get rebuilt, force the issue
        rm -f ${S}/libltdl/config/ltmain.sh
index 18188ef7f34c717c2ea76522f7ec845ac1439cc9..df73f08e99ebae3b8bd1660325bfd75c3dd5c03f 100644 (file)
@@ -8,7 +8,6 @@ SRC_URI += "file://prefix.patch"
 inherit native
 
 EXTRA_OECONF = " --with-libtool-sysroot=${STAGING_DIR_NATIVE}"
-CACHED_CONFIGUREVARS += "ac_cv_path_SED=/bin/sed"
 
 do_configure_prepend () {
        # Remove any existing libtool m4 since old stale versions would break
index 9f0b8a1c194bde95d5d3aec313314793028e749c..c9ec2d26553fbf6ed7c138f33c02e375e01a6d88 100644 (file)
@@ -63,6 +63,7 @@ do_configure () {
                -Di_syslog \
                -Duseperlio \
                -Dman3ext=3pm \
+               -Dsed=/bin/sed \
                -Uafs \
                -Ud_csh \
                -Uusesfio \
index 1214a13515a599d95de9278627334ea9f831c596..5ccc14f8c95246d127f2e3b7d0a6fa26db9431f8 100644 (file)
@@ -17,3 +17,5 @@ shadow_cv_passwd_dir=${bindir}
 
 # python: deactivate a runtime check for ipv6-support in python >=2.7.1 that fails when cross-compiling
 ac_cv_buggy_getaddrinfo=no
+
+ac_cv_path_SED=sed