]> code.ossystems Code Review - openembedded-core.git/commitdiff
gconf: Avoid error when trying to delete files that don't exist
authorPhil Blundell <philb@gnu.org>
Wed, 17 Oct 2012 22:25:17 +0000 (23:25 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 18 Oct 2012 11:07:29 +0000 (12:07 +0100)
Use "rm -f" in do_install_append() so we don't fail if the files we're
trying to delete have already been removed.  This can happen if the
distro policy suppresses both static libs and .la files.

Signed-off-by: Phil Blundell <pb@pbcl.net>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-gnome/gnome/gconf_3.2.3.bb

index dc3520fc1ce3289398046b0743116c587f6d4fef..4d77a14f81b4782e04619f71f789464b5b12fd03 100644 (file)
@@ -33,8 +33,8 @@ do_install_append() {
        install -d ${D}${sysconfdir}/gconf/gconf.xml.system
 
        # this stuff is unusable
-       rm ${D}${libdir}/GConf/*/*.*a
-       rm ${D}${libdir}/gio/*/*.*a
+       rm -f ${D}${libdir}/GConf/*/*.*a
+       rm -f ${D}${libdir}/gio/*/*.*a
 }
 
 # disable dbus-x11 when x11 isn't in DISTRO_FEATURES