]> code.ossystems Code Review - openembedded-core.git/commitdiff
at: fix for parallel build issue & bug #180
authorNitin A Kamble <nitin.a.kamble@intel.com>
Thu, 2 Sep 2010 17:04:19 +0000 (10:04 -0700)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 2 Sep 2010 21:17:11 +0000 (22:17 +0100)
parallel build was failing inconsistently due to missing dependancy
specification in the make file. Fixed it with a new patch.

Bug 180 reported this issue:
| arm-poky-linux-gnueabi-gcc -march=armv5te -mtune=arm926ej-s -c -I.
-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2
-ggdb
-feliminate-unused-debug-types -DHAVE_CONFIG_H -DVERSION=\"3.1.12\"
-DETCDIR=\"/etc\" -DLOADAVG_MX=0.8 -DDAEMON_USERNAME=\"daemon\"
-DDAEMON_GROUPNAME=\"daemon\" -DLFILE=\"/var/spool/cron/atjobs/.SEQ\"
-Wall
atd.c
| atd.c:511:2: error: #error "No mail command specified."
| make: *** [atd.o] Error 1

Fixed it with the recommended solution of defining SENDMAIL as /bin/true

Fixes [BUGID #180]

Reorganized the recipe file for cleanlyness.
Add the init script for at

As per Scott's wiki instructions added the this init script for at:
http://git.buildroot.net/buildroot/tree/package/at/S99at

add libpam to dependancy
And bumped PR.

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
meta/recipes-extended/at/at-3.1.12/fix_parallel_build_error.patch [new file with mode: 0644]
meta/recipes-extended/at/at.inc [deleted file]
meta/recipes-extended/at/at_3.1.12.bb
meta/recipes-extended/at/files/S99at [new file with mode: 0644]

diff --git a/meta/recipes-extended/at/at-3.1.12/fix_parallel_build_error.patch b/meta/recipes-extended/at/at-3.1.12/fix_parallel_build_error.patch
new file mode 100644 (file)
index 0000000..6383660
--- /dev/null
@@ -0,0 +1,24 @@
+make -j was failing sometimesa like this
+| ccache i586-poky-linux-gcc -march=i586 --sysroot=/home/nitin/build/build0/tmp/sysroots/i586-poky-linux -I. -fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2 -ggdb -feliminate-unused-debug-types -o atd atd.o daemon.o  -lfl  -lpam -Wl,-O1 -Wl,--as-needed
+| parsetime.l:5:19: fatal error: y.tab.h: No such file or directory
+| compilation terminated.
+| make: *** [lex.yy.o] Error 1
+| make: *** Waiting for unfinished jobs....
+
+Fixed the issue by adding a dependancy in the makefile.
+Nitin <nitin.a.kamble@intel.com>
+2010/09/02
+
+Index: at-3.1.12/Makefile.in
+===================================================================
+--- at-3.1.12.orig/Makefile.in
++++ at-3.1.12/Makefile.in
+@@ -83,6 +83,8 @@ y.tab.c y.tab.h: parsetime.y
+ lex.yy.c: parsetime.l
+       $(LEX) -i parsetime.l
++parsetime.l: y.tab.h
++
+ atrun: atrun.in
+       configure
diff --git a/meta/recipes-extended/at/at.inc b/meta/recipes-extended/at/at.inc
deleted file mode 100644 (file)
index 64ae9c2..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-DESCRIPTION = "Delayed job execution and batch processing"
-SECTION = "base"
-DEPENDS = "flex"
-RCONFLICTS_${PN} = "atd"
-RREPLACES_${PN} = "atd"
-
-inherit autotools
-
-do_install () {
-    oe_runmake "IROOT=${D}" install
-}
index 605179b21fb6280eef7fcff4f6d73590520b477a..bec09b69585c9d7184138c1491ecca49c432db2f 100644 (file)
@@ -1,19 +1,39 @@
-require at.inc
-
+DESCRIPTION = "Delayed job execution and batch processing"
+SECTION = "base"
 LICENSE="GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
-
-PR = "r1"
+DEPENDS = "flex libpam initscripts"
+RCONFLICTS_${PN} = "atd"
+RREPLACES_${PN} = "atd"
+PR = "r2"
 
 SRC_URI = "${DEBIAN_MIRROR}/main/a/at/at_${PV}.orig.tar.gz \
     file://configure.patch \
     file://nonrootinstall.patch \
     file://use-ldflags.patch \
+    file://fix_parallel_build_error.patch \
     file://posixtm.c \
     file://posixtm.h \
-    file://file_replacement_with_gplv2.patch"
+    file://file_replacement_with_gplv2.patch \
+    file://S99at"
+
+EXTRA_OECONF += "ac_cv_path_SENDMAIL=/bin/true \
+                 --with-daemon_username=root \
+                 --with-daemon_groupname=root \
+                 --with-jobdir=/var/spool/cron/atjobs \
+                 --with-atspool=/var/spool/cron/atspool"
+
+inherit autotools
 
 do_compile_prepend () {
-       mv ${WORKDIR}/posixtm.[ch] ${S}
+       cp -f ${WORKDIR}/posixtm.[ch] ${S}
 }
 
+do_install () {
+       oe_runmake "IROOT=${D}" install
+
+       install -d ${D}${sysconfdir}/init.d
+       install -d ${D}${sysconfdir}/rcS.d
+       install -m 0755    ${WORKDIR}/S99at             ${D}${sysconfdir}/init.d/at
+       ln -sf          ../init.d/at            ${D}${sysconfdir}/rcS.d/S99at
+}
diff --git a/meta/recipes-extended/at/files/S99at b/meta/recipes-extended/at/files/S99at
new file mode 100644 (file)
index 0000000..bcfcbda
--- /dev/null
@@ -0,0 +1,39 @@
+#!/bin/sh
+#
+# Starts at daemon
+#
+
+umask 077
+
+start() {
+       echo -n "Starting atd: "
+       start-stop-daemon --start --quiet --make-pidfile --pidfile /var/run/atd.pid --background --exec /usr/sbin/atd -- -f
+       echo "OK"
+}
+stop() {
+       echo -n "Stopping atd: "
+       start-stop-daemon --stop --quiet --pidfile /var/run/atd.pid
+       echo "OK"
+}
+restart() {
+       stop
+       start
+}
+
+case "$1" in
+  start)
+       start
+       ;;
+  stop)
+       stop
+       ;;
+  restart|reload)
+       restart
+       ;;
+  *)
+       echo $"Usage: $0 {start|stop|restart}"
+       exit 1
+esac
+
+exit $?
+