]> code.ossystems Code Review - openembedded-core.git/commitdiff
udev-164: don't hardcode path to pidof
authorAndreas Oberritter <obi@opendreambox.org>
Thu, 8 Mar 2012 12:08:50 +0000 (13:08 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 8 Mar 2012 19:41:26 +0000 (11:41 -0800)
* pidof lives in /bin, search it in $PATH.
* Assume pidof's presence.

Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/udev/udev/init
meta/recipes-core/udev/udev_164.bb

index 78b5b1c4b66ecd8492bff54451e4a997e990d047..f9e90146e1ed322d253b3d471986c6b1590a2dac 100644 (file)
@@ -28,10 +28,8 @@ readfile () {
 }
 
 kill_udevd() {
-       if [ -x /sbin/pidof ]; then
-               pid=`/sbin/pidof -x udevd`
-               [ -n "$pid" ] && kill $pid
-       fi
+       pid=`pidof -x udevd`
+       [ -n "$pid" ] && kill $pid
 }
 
 export ACTION=add
index b993a13fb52b44d2ade990e1db81168e42984b64..d66104413b0ea738023fe8b6b3929781f4976a15 100644 (file)
@@ -1,6 +1,6 @@
 include udev.inc
 
-PR = "r11"
+PR = "r12"
 
 SRC_URI += "file://udev-166-v4l1-1.patch"