]> code.ossystems Code Review - openembedded-core.git/commitdiff
libtool: update patches
authorNitin A Kamble <nitin.a.kamble@intel.com>
Tue, 13 Jul 2010 12:16:47 +0000 (05:16 -0700)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 15 Jul 2010 12:46:06 +0000 (13:46 +0100)
As per discussion with RP remove dolt patches.
Merge Gary Thomas's patch into trailigslash.patch

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/libtool/libtool-cross_2.2.10.bb
meta/packages/libtool/libtool-native_2.2.10.bb
meta/packages/libtool/libtool-nativesdk_2.2.10.bb
meta/packages/libtool/libtool.inc
meta/packages/libtool/libtool/add_dolt.patch [deleted file]
meta/packages/libtool/libtool/dolt.m4 [deleted file]
meta/packages/libtool/libtool/trailingslash.patch
meta/packages/libtool/libtool_2.2.10.bb

index a1164c9500bc4b7b539980c9f88115e651efb7aa..23135f7edb8205a87369d844feb67b70e38818dc 100644 (file)
@@ -1,19 +1,12 @@
 require libtool_${PV}.bb
 
-PR = "r0"
+PR = "r1"
 PACKAGES = ""
 SRC_URI_append = " file://cross_compile.patch \
                   file://prefix.patch "
 
 DEPENDS += "libtool-native"
 
-DOLT_PATCH = ""
-DOLT_PATCH_arm = " file://add_dolt.patch"
-DOLT_PATCH_i586 = " file://add_dolt.patch"
-
-#SRC_URI_append_linux = "${DOLT_PATCH}"
-#SRC_URI_append_linux-gnueabi = "${DOLT_PATCH}"
-
 do_configure_prepend () {
        # Remove any existing libtool m4 since old stale versions would break
        # any upgrade
@@ -31,7 +24,6 @@ do_install () {
        install -c -m 0644 ${S}/libltdl/config/ltmain.sh ${D}${datadir}/libtool/
        install -c -m 0644 ${S}/libltdl/m4/libtool.m4 ${D}${datadir}/aclocal/
        install -c -m 0644 ${S}/libltdl/m4/ltdl.m4 ${D}${datadir}/aclocal/
-       install -c -m 0644 ${WORKDIR}/dolt.m4 ${D}${datadir}/aclocal/
 }
 
 SYSROOT_PREPROCESS_FUNCS += "libtoolcross_sysroot_preprocess"
index f10ea8836b6458a930aafac7cbf14ae0ee9c020c..322da4a99be10ff33d2d437f39ce2545182700ee 100644 (file)
@@ -2,7 +2,7 @@ require libtool_${PV}.bb
 
 DEPENDS = ""
 
-PR = "r0"
+PR = "r1"
 SRC_URI_append = " file://cross_compile.patch \
                   file://prefix.patch "
 
index c9f24a95bffcdc89e7c801548409dae713302ca7..e972d9ef3daaf41480e7162e2df0b8c1e08781b3 100644 (file)
@@ -1,6 +1,6 @@
 require libtool_${PV}.bb
 
-PR = "r0"
+PR = "r1"
 SRC_URI_append = " file://cross_compile.patch \
                   file://prefix.patch "
 
index a14068f279898f0fce695581eea67a18c1e6ee43..c94dadd0afcccd817f7fb59d31628ed87db39c54 100644 (file)
@@ -10,6 +10,5 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
 
 SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
            file://trailingslash.patch \
-           file://prefix-manpage-fix.patch \
-           file://dolt.m4 "
+           file://prefix-manpage-fix.patch "
 
diff --git a/meta/packages/libtool/libtool/add_dolt.patch b/meta/packages/libtool/libtool/add_dolt.patch
deleted file mode 100644 (file)
index 2c5df96..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: libtool-2.2.2/libltdl/m4/libtool.m4
-===================================================================
---- libtool-2.2.2.orig/libltdl/m4/libtool.m4   2008-04-13 22:40:30.000000000 +0100
-+++ libtool-2.2.2/libltdl/m4/libtool.m4        2008-04-13 23:38:45.000000000 +0100
-@@ -97,6 +97,7 @@
- # Only expand once:
- m4_define([LT_INIT])
-+DOLT
- ])# LT_INIT
- # Old names:
diff --git a/meta/packages/libtool/libtool/dolt.m4 b/meta/packages/libtool/libtool/dolt.m4
deleted file mode 100644 (file)
index 9bedecf..0000000
+++ /dev/null
@@ -1,129 +0,0 @@
-dnl dolt, a replacement for libtool
-dnl Copyright © 2007-2008 Josh Triplett <josh@freedesktop.org>
-dnl Copying and distribution of this file, with or without modification,
-dnl are permitted in any medium without royalty provided the copyright
-dnl notice and this notice are preserved.
-dnl
-dnl To use dolt, invoke the DOLT macro immediately after the libtool macros.
-dnl Optionally, copy this file into acinclude.m4, to avoid the need to have it
-dnl installed when running autoconf on your project.
-
-AC_DEFUN([DOLT], [
-AC_REQUIRE([AC_CANONICAL_HOST])
-# dolt, a replacement for libtool
-# Josh Triplett <josh@freedesktop.org>
-AC_PATH_PROG(DOLT_BASH, bash)
-AC_MSG_CHECKING([if dolt supports this host])
-dolt_supported=yes
-if test x$DOLT_BASH = x; then
-    AC_MSG_ERROR([dolt: Bash not found, fatal error])
-fi
-if test x$GCC != xyes; then
-    AC_MSG_ERROR([dolt: gcc not found, fatal error])
-fi
-case $host in
-i?86-*-linux*|x86_64-*-linux*|arm-*-linux*) ;;
-*) AC_MSG_ERROR([dolt: incompatible host, fatal error]) ;;
-esac
-AC_MSG_RESULT([yes, replacing libtool])
-
-dnl Start writing out doltcompile.
-    cat <<__DOLTCOMPILE__EOF__ >doltcompile
-#!$DOLT_BASH
-__DOLTCOMPILE__EOF__
-    cat <<'__DOLTCOMPILE__EOF__' >>doltcompile
-args=("$[]@")
-for ((arg=0; arg<${#args@<:@@@:>@}; arg++)) ; do
-    if test x"${args@<:@$arg@:>@}" = x-o ; then
-        objarg=$((arg+1))
-        break
-    fi
-done
-if test x$objarg = x ; then
-    echo 'Error: no -o on compiler command line' 1>&2
-    exit 1
-fi
-lo="${args@<:@$objarg@:>@}"
-obj="${lo%.lo}"
-if test x"$lo" = x"$obj" ; then
-    echo "Error: libtool object file name \"$lo\" does not end in .lo" 1>&2
-    exit 1
-fi
-objbase="${obj##*/}"
-__DOLTCOMPILE__EOF__
-
-dnl Write out shared compilation code.
-    if test x$enable_shared = xyes; then
-        cat <<'__DOLTCOMPILE__EOF__' >>doltcompile
-libobjdir="${obj%$objbase}.libs"
-if test ! -d "$libobjdir" ; then
-    mkdir "$libobjdir"
-    mkdir_ret=$?
-    if test "$mkdir_ret" -ne 0 && test ! -d "$libobjdir" ; then
-        exit $mkdir_ret
-    fi
-fi
-pic_object="$libobjdir/$objbase.o"
-args@<:@$objarg@:>@="$pic_object"
-"${args@<:@@@:>@}" -fPIC -DPIC
-__DOLTCOMPILE__EOF__
-    fi
-
-dnl Write out static compilation code.
-dnl Avoid duplicate compiler output if also building shared objects.
-    if test x$enable_static = xyes; then
-        cat <<'__DOLTCOMPILE__EOF__' >>doltcompile
-non_pic_object="$obj.o"
-args@<:@$objarg@:>@="$non_pic_object"
-__DOLTCOMPILE__EOF__
-        if test x$enable_shared = xyes; then
-            cat <<'__DOLTCOMPILE__EOF__' >>doltcompile
-"${args@<:@@@:>@}" >/dev/null 2>&1
-__DOLTCOMPILE__EOF__
-        else
-            cat <<'__DOLTCOMPILE__EOF__' >>doltcompile
-"${args@<:@@@:>@}"
-__DOLTCOMPILE__EOF__
-        fi
-    fi
-
-dnl Write out the code to write the .lo file.
-dnl The second line of the .lo file must match "^# Generated by .*libtool"
-    cat <<'__DOLTCOMPILE__EOF__' >>doltcompile
-{
-echo "# $lo - a libtool object file"
-echo "# Generated by doltcompile, not libtool"
-__DOLTCOMPILE__EOF__
-
-    if test x$enable_shared = xyes; then
-        cat <<'__DOLTCOMPILE__EOF__' >>doltcompile
-echo "pic_object='$pic_object'"
-__DOLTCOMPILE__EOF__
-    else
-        cat <<'__DOLTCOMPILE__EOF__' >>doltcompile
-echo pic_object=none
-__DOLTCOMPILE__EOF__
-    fi
-
-    if test x$enable_static = xyes; then
-        cat <<'__DOLTCOMPILE__EOF__' >>doltcompile
-echo "non_pic_object='$non_pic_object'"
-__DOLTCOMPILE__EOF__
-    else
-        cat <<'__DOLTCOMPILE__EOF__' >>doltcompile
-echo non_pic_object=none
-__DOLTCOMPILE__EOF__
-    fi
-
-    cat <<'__DOLTCOMPILE__EOF__' >>doltcompile
-} > "$lo"
-__DOLTCOMPILE__EOF__
-
-dnl Done writing out doltcompile; substitute it for libtool compilation.
-    chmod +x doltcompile
-    LTCOMPILE='$(top_builddir)/doltcompile $(COMPILE)'
-    AC_SUBST(LTCOMPILE)
-    LTCXXCOMPILE='$(top_builddir)/doltcompile $(CXXCOMPILE)'
-    AC_SUBST(LTCXXCOMPILE)
-# end dolt
-])
index f51c06406eff3846ce3552de2b6e2b9614c4b296..313c26291aace860d21367f1db8a9ab30c15d707 100644 (file)
@@ -4,21 +4,29 @@ This is because libdir has a trailing slash which breaks the comparision.
 
 RP 2/1/10
 
+Merged a patch received from Gary Thomas <gary@mlbassoc.com>
+
+Date: 2010/07/12
+Nitin A Kamble <nitin.a.kamble@intel.com>
+
 Index: libtool-2.2.10/libltdl/config/ltmain.m4sh
 ===================================================================
 --- libtool-2.2.10.orig/libltdl/config/ltmain.m4sh
 +++ libtool-2.2.10/libltdl/config/ltmain.m4sh
-@@ -1634,8 +1634,12 @@ func_mode_install ()
+@@ -1634,8 +1634,15 @@ func_mode_install ()
        dir="$dir$objdir"
  
        if test -n "$relink_command"; then
 +      # Strip any trailing slash from the destination.
 +      func_stripname '' '/' "$libdir"
 +      destlibdir=$func_stripname_result
++
++      func_stripname '' '/' "$destdir"
++      s_destdir=$func_stripname_result
 +
          # Determine the prefix the user has applied to our future dir.
 -        inst_prefix_dir=`$ECHO "$destdir" | $SED -e "s%$libdir\$%%"`
-+        inst_prefix_dir=`$ECHO "X$destdir" | $Xsed -e "s%$destlibdir\$%%"`
++        inst_prefix_dir=`$ECHO "X$s_destdir" | $Xsed -e "s%$destlibdir\$%%"`
  
          # Don't allow the user to place us outside of our expected
          # location b/c this prevents finding dependent libraries that
index cca3b1ea4a60978536e51e3f8ee40227d042ace0..9eaec2da670da15774d1c35519c5c441539a7bb1 100644 (file)
@@ -1,7 +1,7 @@
 require libtool.inc
 DEPENDS = "libtool-native"
 
-PR = "r0"
+PR = "r1"
 
 PACKAGES =+ "libltdl libltdl-dev libltdl-dbg"
 FILES_${PN} += "${datadir}/aclocal*"