]> code.ossystems Code Review - openembedded-core.git/commitdiff
llvm: fix upstream version check
authorAlexander Kanavin <alex.kanavin@gmail.com>
Thu, 19 Dec 2019 13:23:00 +0000 (14:23 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 30 Dec 2019 08:45:03 +0000 (08:45 +0000)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/llvm/llvm_git.bb

index cb2e1164cfb25906b45a0bbc1a90654d444f46dd..3b0a1b3b276fb36032edfff3a660cc23edaf09dc 100644 (file)
@@ -35,6 +35,8 @@ SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH} \
            file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
           "
 
+UPSTREAM_CHECK_GITTAGREGEX = "llvmorg-(?P<pver>\d+(\.\d+)+)"
+
 S = "${WORKDIR}/git/llvm"
 
 LLVM_INSTALL_DIR = "${WORKDIR}/llvm-install"