]> code.ossystems Code Review - openembedded-core.git/commitdiff
kbd: fix ptest can NOT run issue
authorKai Kang <kai.kang@windriver.com>
Tue, 24 Dec 2019 01:54:49 +0000 (09:54 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 30 Dec 2019 08:45:03 +0000 (08:45 +0000)
After kbd updated to 2.2.0, it fails to run ptest:

| make: *** No rule to make target 'libkbdfile-test01.c', needed by 'libkbdfile-test01'.

Update sed expression to fix such kind of issues. And also make target
dumpkeys-bkeymap and dumpkeys-bkeymap which are required by ptest.

Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/kbd/kbd_2.2.0.bb

index f2521617e53c6eef7095f6f53a12acba2fb11dc9..88041bc87890ce86fa314238ff36caf08c74b485 100644 (file)
@@ -29,7 +29,7 @@ PACKAGECONFIG[pam] = "--enable-vlock, --disable-vlock, libpam,"
 PACKAGECONFIG[tests] = "--enable-tests, --disable-tests, libcheck"
 
 do_compile_ptest() {
-    oe_runmake -C ${B}/tests dumpkeys-fulltable alt-is-meta
+    oe_runmake -C ${B}/tests alt-is-meta dumpkeys-bkeymap dumpkeys-fulltable dumpkeys-mktable
 }
 
 do_install_ptest() {
@@ -42,7 +42,7 @@ do_install_ptest() {
        -e 's:${RECIPE_SYSROOT}::g' \
        -e 's:${S}/config/missing::g' \
        -e 's:${WORKDIR}::g' \
-       -e '/libkeymap_.*_SOURCES =/d' -e '/$(EXEEXT):/,/^$/d' ${D}${PTEST_PATH}/tests/Makefile
+       -e '/^lib.*_SOURCES =/d' -e '/$(EXEEXT):/,/^$/d' ${D}${PTEST_PATH}/tests/Makefile
 
     find ${B}/tests -executable -exec install {} ${D}${PTEST_PATH}/tests \;
     find ${S}/tests \( -name \*.map -o -name \*.bin -o -name \*.output \) -exec install {} ${D}${PTEST_PATH}/tests \;